Raypak Heater Display Blank

abrocojo

Member
Mar 30, 2014
22
Indiana
I have a Raypak 266A-E_X heater. the display went out so I replaced it with a new one but now it lights up but is blank. I hooked everything back up correctly. Is there something else that could be wrong?
 

abrocojo

Member
Mar 30, 2014
22
Indiana
So I think I may have messed up the display when I installed it. It says to remove the protective film. But it wasn’t like there was a think piece of protective covering . So I pulled and scraped and got a thick layer off . It was a green layer. Now I wonder if that was a necessary layer and mine didn’t have a protective film. Is the display supposed to be green or clear? The glass on the display I mean.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
18,959
Northern NJ
The type of protective film that comes on displays is just a clear thin plastic that easily peels off. It should not be thick or need to be scraped.

Write it off to a DIY learning experince and buy another display.
 

abrocojo

Member
Mar 30, 2014
22
Indiana
Hi I replaced the display and it is still blank. The display lights up but is blank. Could I have a short in a connector to the circuit board?
 

abrocojo

Member
Mar 30, 2014
22
Indiana
Could it be my display is bad? I got it on amazon. Maybe I should try another display from some place that I am guaranteed is supplying me with a good display. Thoughts?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
18,959
Northern NJ
It could be that your display board was never the problem and the display driver or something else fried in the main board.

@ogdento plays with this stuff and may have some ideas how to test.

Show us some pics of the main board around the display socket and what the display looks like.
 

ogdento

Bronze Supporter
Mar 30, 2015
530
Chico, CA
Allen might be right here... in addition to the photos he asked for, can you send a link to the display you got? And is this just a 16x2 line display?
 

abrocojo

Member
Mar 30, 2014
22
Indiana
1F4172B2-BCA1-4D7F-9FDA-6C73DC5A8D5D.jpeg
here is the circuit board. the old circuit board fired up the heater so it worked. It was just the display that didn’t. The old display didn’t light up at all. But the board worked. I bought a new board and it didn’t even fire up the heater and the display just lit up but was blank so I put the old board back in and bought just the display and the new display lit up and was blank too. I bought both on amazon. So wondering if what I am getting on amazon is junk. Here is the link to the display on amazon

Raypak 013640F LCD Display Pool Stat-Kit Amazon.com: Raypak 013640F LCD Display Pool Stat-Kit: Garden & Outdoor
 

Rainbow7

Member
Jun 3, 2020
20
Orlando
Hi there my heater is doing the exact same thing, I have a light but no words. Did you ever get yours resolved? Curious as to what your resolution was?? TIA
 

Rainbow7

Member
Jun 3, 2020
20
Orlando
View attachment 137731
here is the circuit board. the old circuit board fired up the heater so it worked. It was just the display that didn’t. The old display didn’t light up at all. But the board worked. I bought a new board and it didn’t even fire up the heater and the display just lit up but was blank so I put the old board back in and bought just the display and the new display lit up and was blank too. I bought both on amazon. So wondering if what I am getting on amazon is junk. Here is the link to the display on amazon

Raypak 013640F LCD Display Pool Stat-Kit Amazon.com: Raypak 013640F LCD Display Pool Stat-Kit: Garden & Outdoor