New Pentair Heater Broken - Rattling Sound, Trying to Diagnose

Sam1234

Gold Supporter
Nov 26, 2020
10
Santa Barbara, CA
Our brand new Pentair heater is broken. We're trying to figure out what could be causing it and if it's a quick fix or we'll need to make a warranty call. We are hoping it is a quick fix, since we're sharing the pool with several other families (with a google calendar so there is no overlap) during covid, so that everyone can get some exercise, and we've also got two very active kids that we've been putting into the pool in wetsuits for now... :( . There is a video here:


What basically happens is that when we turn on the heater, there is a rattling sound (all over, like something is being flung around inside the heater - very similar to the sound of metal buttons etc. hitting inside a dryer when it's on). Then the heater shoots up to about 110, the heater shuts off, and the temperature slowly (over maybe an hour) comes back down. Any thoughts on what this could possibly be would be very welcome.
 
Last edited:

Killer95Stang

Well-known member
Aug 17, 2012
892
Sunny SoCal
Did you verify the water temp actually hits 110 degrees? You can use any type of thermometer (human, meat, laser) to check, so you can rule out any issues with the heaters temperature sensor. Also, every time I've had that rock tumbler sound, I found I needed to change out the thermal regulator. My unit would also short cycle, heat up until it reaches a fault and then turn off until it resets and starts all over again. I've also read that the bypass valve can also make noise, because they break often. I've never had the second issue, but I bought one that sits on the shelf.

But... if it was me and I still had warranty, I would call Pentair to get it fixed. This is the off season, so they might get to it a little faster. Not to mention, a lot of things can go wrong with these heaters, I've just been lucky being able to diagnose using this site and youtube.
 

Attachments

  • 717LmPz09OL._AC_SL1500_.jpg
    717LmPz09OL._AC_SL1500_.jpg
    68.3 KB · Views: 0
  • 96899_0_2018417125659.jpg
    96899_0_2018417125659.jpg
    25 KB · Views: 0

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
23,633
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
You have an over temp condition in the heater causing the water to boil. The boiling causes the knocking. This is usually caused by low water flow.

Check the filter pressure and clean the filter.

Increase the pump RPMS if you have an VS pump.

Please provide more detail in your signature about your pool and equipment for us to give more specific recommendations.
 
  • Like
Reactions: JamesW

JamesW

TFP Expert
Mar 2, 2011
23,200
Is the In/out correct?

Check the thermal regulator.

Do you have a picture of the plumbing?

Maybe a valve misconfiguration.
 

Killer95Stang

Well-known member
Aug 17, 2012
892
Sunny SoCal
Check the thermal bypass.

James, maybe you can shed some light on this for me. I've had similar issues like the OP, with the noises, and short cycling. Both times fixed by replacing the thermal bypass. Both times, I couldn't see anything wrong with the part I pulled out, but sure enough it always fixed the problem. What am I looking for?
 

JamesW

TFP Expert
Mar 2, 2011
23,200
It's almost definitely a water flow problem.

There is probably close to zero flow through the heater.
 

JamesW

TFP Expert
Mar 2, 2011
23,200
James, maybe you can shed some light on this for me. I've had similar issues like the OP, with the noises, and short cycling. Both times fixed by replacing the thermal bypass. Both times, I couldn't see anything wrong with the part I pulled out, but sure enough it always fixed the problem. What am I looking for?
The thermal regulator should open at 120 degrees.

The opening is rather small and it might cause too much restriction if it does not open fully at the correct temperature.

You can test it in hot water.

I would try it in water at 110, 115, 120, 125 etc. to see where it fully opens.

In my opinion, if I was the manufacturer, I would redesign the heater to get rid of the thermal regulator and use an external three-way valve bypass with a valve actuator driven from 24 VAC from the heater controls.

I would use a real flow switch and go to a single pass heat exchanger.

In the OP’s case, since it’s brand new, the thermal regulator is a possible problem but the more likely problem is a plumbing error.

 
Last edited: