Screenlogic won't change *cooling* temperature for Pentair Ultratemp heatpump

meatty

Member
Jun 22, 2019
9
Austin, TX
I am having the EXACT same issue as this thread: ScreenLogic2 with UltraTemp heatPump

Basically, setting the cool temperature on screenlogic does not actually affect the settings that my easytouch control panel has, but all other functions of screenlogic work fine. I have it all set as everything tells me it should be. I CAN set the cooling temperature directly from the panel, just not from screenconnect. Has anyone managed to solve this?

107737
 

meatty

Member
Jun 22, 2019
9
Austin, TX
Hello,

Thanks for the responses! Living in Austin, TX, with a gray autocover, we're seeing temps hitting 90 in the pool now, so trying to get it a little less bathwater-like.
Here are the screenshots requested:

107761



107760

If I change that 90 (which is the same as is set at the easytouch control panel), it doesn't turn on the chiller, and actually bounces back to 90 after about 30 seconds. Same problem if I change it on my phone. Changing directly on the control panel, however, turns on the chiller.

Thanks
 

meatty

Member
Jun 22, 2019
9
Austin, TX
Impossible if I want anything else set - those four are sequentially dependent. Has cooling depends on Ultraflow depends on Solar is a Heat Pump depends on Solar Present. So deselecting Solar present deselects everything.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
14,188
Bedford, TX
If this were my system, I would go to Menu, Settings, Heat Pump com menu, Settings

Then turn heat off and make sure cooling is on...

I only say this because of the fact that the cooling temp seems to change and then jumps back to 90.. It sounds to me like the system is still in the heat mode.

I am not sure this is true, but it would be a pretty simple test.

Thanks,

Jim R.
 

meatty

Member
Jun 22, 2019
9
Austin, TX
Are you saying to do that on the Easytouch? I'll definitely try it, but I'm a little confused - I can't find those options on screenlogic.

On the easytouch panel, changing the cooling temperature works fine.
 

JamesW

TFP Expert
Mar 2, 2011
16,339
Go to Solar and disable Solar. Then, go to Heat Pump and enable Heat Pump.

MENU>SETTINGS>HEAT PUMP COM>SETTINGS

Right button: Access the “Settings” menu.
Up/Down buttons: Select Yes or No to enable or disable UltraTemp.
Right button: Move to the “Heating” setting.
Up/Down buttons: Select Yes or No to use for heating.
Right button: Move to the “Cooling” setting.
Up/Down buttons: Select Yes or No to use for cooling only or if the unit is reversible select both heating and cooling.
Press the Menu button to save the settings and to return to the Heat Pump Com Settings and Status menu options.
Press the Menu button three times to return to the main screen.
 

JamesW

TFP Expert
Mar 2, 2011
16,339
You might be able to leave solar like it is except disable cooling. Then, enable Heat pump and enable cooling but not heating.
 

meatty

Member
Jun 22, 2019
9
Austin, TX
Right, was just confirming you were talking about the Easytouch control panel, not the screenlogic app.

pretty sure I tried that previously, but I'll give it a shot. We're about to have a thunderstorm, so I need to wait until that passes! will report results!
 

meatty

Member
Jun 22, 2019
9
Austin, TX
I tried that, didn't help:
107901
Solar screen says this when I try to go to it, so it's impossible to disable (same as in the screenlogic app):
107902
When I change the temperature on the app, it does not reflect here, but if I change it here, it activates cooling correctly (also, it does reflect in the app when I change it here):
107903

Also, I know that the easytouch to ultratemp cooling is working because as soon as it flips from spa to pool, and still has spa water in the temperature sensor, the cooling kicks on for a few seconds until it clears that water and the pool water replaces it. That's kind of annoying - does anyone know of a delay that can be set anywhere to make it not kick on for a minute or so of a temperature?

Any other suggestions?

Thanks for all your help!
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
22,396
Laughlin, NV
There are Delays built into the Easytouch, but I am not sure if what you want will apply. There is a delay for the heater but it is for cooldown purposes.
 

Rocket J Squirrel

Bronze Supporter
Jun 7, 2018
517
Alamo, CA
I ran into this issue with the ET8 wired and wireless controllers. Neither will accept the setting for night cooling. Only the outdoor panel will allow it. For the controllers, it’s a result of having older firmware than the panel. In other words, it’s a bug. Sounds like ScreenLogic has the same bug.
 

meatty

Member
Jun 22, 2019
9
Austin, TX
I ran into this issue with the ET8 wired and wireless controllers. Neither will accept the setting for night cooling. Only the outdoor panel will allow it. For the controllers, it’s a result of having older firmware than the panel. In other words, it’s a bug. Sounds like ScreenLogic has the same bug.

Thanks - I'll get in touch with Pentair... maybe they'll update something!