New (and first ever) Pool! Dallas, TX

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
14,467
Bedford, TX
A,

I would go with the CCP 520 filter... the 420 will work fine, but the bigger the filter the less often you have to clean it. I doubt in the long run that you will ever be able to remember the difference in cost between the two..

You can tell the pool builder to drop the Salt cell power center P/N 520556, as the ET 4, P/N 520543, comes with it inside already.. You can't use two of them, so don't let him charge you for it...
I also would scrap the booster pump and pressure side cleaner and go with a robot.. I might have been born a long time ago, but I live in this century... :)

Thanks,

Jim R.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
10,562
Northern NJ
I happen to like a pressure cleaner but would not get the Racer LS 360330. I prefer the Polaris 380 and its booster pump.

There are pros and cons to each type of cleaner. Whatever people have they think is the best. Look through the Pool Cleaners section and decide which type of problems you would rather deal with.
 

bmoreswim

Mod Squad
Gold Supporter
Platinum Supporter
LifeTime Supporter
Jul 16, 2012
5,416
Central MD
Another strong vote for a robot here. I had a pressure side cleaner and its cleaning ability for dust like debris was much worse than my Dolphin. Like night and day difference from my perspective. Could there have been a better pressure side cleaner? Sure, but I'm not looking back. And I don't have a booster in my system now either. Since I don't like the look of a cleaner in the pool, the best practice of removing a robot isn't a problem for me. I only need to run it once a week.
 

Awap14

Silver Supporter
Nov 27, 2018
234
Dallas, TX
A,

I would go with the CCP 520 filter... the 420 will work fine, but the bigger the filter the less often you have to clean it. I doubt in the long run that you will ever be able to remember the difference in cost between the two..

You can tell the pool builder to drop the Salt cell power center P/N 520556, as the ET 4, P/N 520543, comes with it inside already.. You can't use two of them, so don't let him charge you for it...
I also would scrap the booster pump and pressure side cleaner and go with a robot.. I might have been born a long time ago, but I live in this century... :)

Thanks,

Jim R.
Hmm I wonder why they would put both in? Do they really not know..? Or maybe they are trying to overcharge but there is no price change from the Jandy price I already paid..I’ll have to look into this. Thanks so much for your response.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
14,467
Bedford, TX
pb,

Looks like only about 50 places sell the cartridges for the 520.. so that is just not true...

A set of cartridges for the 520 cost about $200 bucks and for the 420 they are about $150 bucks...... Maybe they meant they were a little less expensive. :scratch:

But since you only need to change them every 8 to 10 years, I'm not seeing that as much of an issue either..

Thanks,

Jim R.
 

Awap14

Silver Supporter
Nov 27, 2018
234
Dallas, TX
Here’s a question - I have one of those expandable hoses and the standard setting without a nozzle on it is pretty high pressure. Is that going to be a problem when I fill the pool for the first time? It isn’t like a pressure washer or anything...but I don’t want it to cause an issue with the pebbletec.
 

kimkats

Mod Squad
LifeTime Supporter
Jul 10, 2012
41,347
Tallahassee, FL
You can put a sock or two over the end of the house and that should soften the flow some. You can also lower the flow from the house bib so it is not as fast.
 

Awap14

Silver Supporter
Nov 27, 2018
234
Dallas, TX
Ok everyone, I really need some help on this one! Our flagstone coping and tile was completed a week or more ago. It has rained since then and I sprayed down the stones and tiles and still noticed a cloudy residue everywhere. I suppose they didn’t wipe everything off with clean water when they were done. The problem is after a careful scrubbing I am not seeing any improvement! Is this normal? I took some pictures that kind of show the issue. I added comments on them too, if anyone has time to take a look. I don’t want to be a bother to the pool builder if this is normal but it looks subpar to me.