Pentair Mastertemp 400 Reverts to Low Temperatures When Activated

Bryman125

Member
Jun 24, 2021
5
Morgan Hill, CA
I am having an issue with my Pentair Mastertemp 400 heater. When I turn on the spa or pool from my phone using Pentair ScreenLogic, or I turn it on manually from the Pentair Easytouch Control System, the heater takes a long time cycling through its startup process and then does not fire up the gas. It is reverting to 70 degrees for the pool and 95 degrees for the spa. I have had no issues with this until recently.

Before, the heater would start up very quickly and was always set at the default of 104 degrees for both pool and spa. Now, every time I turn it on, it reverts back to 70 degrees for the pool and 95 degrees for the spa. Once I turn the set temperature up to 104, the heater starts up right away.

It is frustrating because if we have the spa on, once it reaches the set temperature, it will turn off and then will not maintain the desired temperature unless I manually go over to the heater and turn the temperature up again. PLEASE HELP!
 

JamesW

TFP Expert
Mar 2, 2011
27,782
I suspect that the "Off" button is sticking.

The ad0 and the SF1 show up when the off button is held down to program the stack flue sensor.

I would file a warranty claim and request that the membrane pad be replaced.

If not under warranty, just replace the membrane pad.

You can use the maxetherm or mastertemp membrane pad.


The Maxetherm and mastertemp heaters are the same except for the outer shell.
 

swamprat69

Well-known member
Mar 30, 2019
580
Las Vegas, NV
Hey Brian... Looks like you finally got time to use this forum... you should fill in your signature with your pool information from the labels on your equipment as it will help anyone trying to answer your questions tremendously
 

Bryman125

Member
Jun 24, 2021
5
Morgan Hill, CA
I suspect that the "Off" button is sticking.

The ad0 and the SF1 show up when the off button is held down to program the stack flue sensor.

I would file a warranty claim and request that the membrane pad be replaced.

If not under warranty, just replace the membrane pad.

You can use the maxetherm or mastertemp membrane pad.


The Maxetherm and mastertemp heaters are the same except for the outer shell.
Thank you so much! This was the issue and I was able to get a new membrane pad under warranty. The heater is working perfectly again. I really appreciate you taking the time to help me resolve this issue.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.