Jandy LT400 LP Gas Heater - rebuilt and fully functioning!

Jameso78

Silver Supporter
Sep 18, 2020
38
North Texas
Pool Size
45000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
Minor update... all is still working perfectly, but have not had any rain yet to test it with... I did run an additional ground wire just to insure I have all my bases covered...I ran it from one of the inducer blower housing flange bolts over to my ground gang, which is actually one of the screws for the 24VAC transformer on the LT400...when it rains again, I'll report back....

Cheers 🍻🍻🍻🥃🥃🥃

James
 

Jameso78

Silver Supporter
Sep 18, 2020
38
North Texas
Pool Size
45000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
Well...we had a some heavy rain last night, so thought I'd give my heater a test this AM... its back to cycling 3 times and air flow error... now I am really stumped... any more thoughts out there about what else could be causing this? I've used it 5+ times per week the past 2 weeks, no issues at all...any and all input appreciated...
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
21,239
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
When outdoor equipment only fails when it is wet out you need to look for areas of corrosion and poor connections that cause bad grounds or high resistance. Based on the history you described in the first post that is very likely.

I would get Stabilant 22 and put it on every connector and connection you can find.

 

Jameso78

Silver Supporter
Sep 18, 2020
38
North Texas
Pool Size
45000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
When outdoor equipment only fails when it is wet out you need to look for areas of corrosion and poor connections that cause bad grounds or high resistance. Based on the history you described in the first post that is very likely.

I would get Stabilant 22 and put it on every connector and connection you can find.

Ajw22...you were spot on! I unscrewed my flame sensor rod and already had rust accumulating on the firebox and sensor flange... I cleaned them, put some di-electric grease on it ( cause that’s all I had right now, left over from using it on light bulbs on my car) , reassembled and it worked perfectly!!! I’ll get the anti-corrosive stuff and hopefully put this issue behind me...
 
  • Like
Reactions: ajw22

Jameso78

Silver Supporter
Sep 18, 2020
38
North Texas
Pool Size
45000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
I am going to color this one done, all working well now! Thanks all! Now onto my next challenge, skimmer leaks! New post on that one though...Cheers...James 🍻 🍻 🍻