Skimmers are not pulling in debris

nrowland622

New member
Apr 4, 2020
2
Savannah, Georgia
Hi! I'm opening the pool during this quarantine and have hit a snag. I've noticed the debris floating on top of the pool is not being sucked into the skimmers? Water is flowing; pump is primed; slide is running; jets are pushing; but when I look into the skimmer, the water appears to be standing still and nothing is being sucked in. I know water is flowing through there because the pump is staying primed. Pressure looks good and the slide is running strong which usually means all my flows are fine. Any ideas? I'm tired of skimming by hand! My pool has no main drain, by the way. The water to the pump only comes through those two skimmers.
 
Last edited:

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
17,070
Bedford, TX
622,

If the water is way too high, the weir door will not work well and the skimmer will not skim well..

Or... if the weir door is missing, or stuck down, you will have the same issue.

Check to make sure that the weir door is working properly..

Thank,s

Jim R.
 
Last edited:

nrowland622

New member
Apr 4, 2020
2
Savannah, Georgia
Thanks for each of your replies! The water level is perhaps 3/4 the way up the skimmer opening so I will drain some and see if that makes a difference. I will also double check the weir doors. Thanks again!
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Do you have a main drain? Have you placed your hand down into the skimmers to feel suction?

Also make sure to update your signature with all of your pool and equipment info. It really helps in posts like this. Make sure to include your test kit as well.
 
Last edited: