Pentair Mastertemp 400-Blank Screen-No Power

Mustang33

Silver Supporter
Mar 20, 2021
20
DFW/Texas
Pool Size
17000
Surface
Plaster
Chlorine
Liquid Chlorine
Brand New Pentair masterTemp 400 heater. After recent big Texas freeze, power was cut off for 3 days. Can’t remember if I had power to Heater once power came back, but don’t believe so. Replaced Basic Manifold to get pool back up and running. But no power at all to heater control panel. All breakers are fine and reset. Any suggestions on how to get power back to the heater so it can run again? Thanks in advance.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,128
Bedford, TX
33,

Did you use a voltmeter and actually test the power going into the heater?

Just because the breakers "look" good, does not mean they are good.

That said, I think the Squirrel has most likely pointed you to the problem..

Thanks,

Jim R.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,117
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
How new is new on the heater?

Who installed it? Did it ever work?

Check the proper AC voltage plug is installed.

1616264077492.png
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,117
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
You have no signature with your equipment.

Is the heater connected to automation?

Is the fireman's switch properly connected?
 

Mustang33

Silver Supporter
Mar 20, 2021
20
DFW/Texas
Pool Size
17000
Surface
Plaster
Chlorine
Liquid Chlorine
Heaters only a few months old. It did work previous to the winter freeze/power loss. The correct 240v plug is plugged in and has never been changed or altered. The company who installed it has been doing it for years....just can’t get him on the phone to go over it.
 

Enjoying this content?

Support TFP with a donation.

Give Support

Mustang33

Silver Supporter
Mar 20, 2021
20
DFW/Texas
Pool Size
17000
Surface
Plaster
Chlorine
Liquid Chlorine
You have no signature with your equipment.

Is the heater connected to automation?

Is the fireman's switch properly connected?
I apologize and wish I knew this basic electrical language, but I don’t.
signature? Automation? I couldn’t tell you if it was correctly connected or not. All I can do is send pics and ask generic questions.
Testing voltage line to line....I’m clueless.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,117
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
I think your ET or IntelliCenter or whatever you have is not calling for heat and closing the fireman's switch or the 2 wire connection has a problem.

Pentair_MasterTemp_Firemans_Switch.jpg
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,117
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
I apologize and wish I knew this basic electrical language, but I don’t.
signature? Automation? I couldn’t tell you if it was correctly connected or not. All I can do is send pics and ask generic questions.
Testing voltage line to line....I’m clueless.

So let's slow down...

It is helpful to all of us to know what equipment you have in your pool. The best way is to create your signature with details of your pool and equipment.

What Pentair control system do you have? That is your automation - EasyTouch? IntelliTouch? IntelliCenter?
 

Mustang33

Silver Supporter
Mar 20, 2021
20
DFW/Texas
Pool Size
17000
Surface
Plaster
Chlorine
Liquid Chlorine
I think your ET or IntelliCenter or whatever you have is not calling for heat and closing the fireman's switch or the 2 wire connection has a problem.

Pentair_MasterTemp_Firemans_Switch.jpg
Would I be able to visually see if either one of those problems is the cause?
Not that this helps....but this is what I’m looking at..... image.jpg
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,117
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
I think the two wires in the black cable that disappears into the upper right of the pic are the "fireman's switch" control cable. The two wires connect into the orange and blue wire nuts in the heater.


Can you follow that black cable out of the heater into where it goes?
 

Enjoying this content?

Support TFP with a donation.

Give Support
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread