Pentair IntelliCenter Review and Information

MyAZPool

Gold Supporter
Jul 3, 2018
1,074
Arizona
@SA Pentair User
In the iOS app - I am now also NOT able to edit an existing schedule. :rolleyes: I am however, able to create (add) a new schedule, just not edit an existing one (so at least you can do that and then delete the existing one that you were trying to edit (yea, I know). I did not have this problem a few days ago, prior to this latest iOS update. Typical. Fix one thing, break something else.

In the web client, I am NOT able to edit an existing schedule mainly because of the ongoing issue regarding the inability to expand the schedule in order to edit.

In the desktop version of the Android app, I AM able to edit and save an existing schedule.

I wonder if anyone else besides us is experiencing the same with regards to the iOS app?
Either way, I guess I'll let TS know on Monday about this new problem. Sheesh...
r,
Hi All,
Just a quick update on this latest iOS app glitch.
I informed Pentair TS about it earlier in the week.
Today I got a response that the issue was pushed to the software dev team, that they are aware, are working it and will issue an update with the fix sometime soon.
Thanks...
r.
 
  • Like
Reactions: SA Pentair User

MyAZPool

Gold Supporter
Jul 3, 2018
1,074
Arizona
FYI
Currently there are ongoing issues with both the Pentair IntelliCenter Alexa App and Apple Watch App.
Yea, like neither are working right now.

Pentair Tech Support reports that the software dev team is aware of this fact and that they confirm that both are down right now and that they are currently working on it.
Right... :scratch: sigh...
r.
 
  • Like
Reactions: Spookie

rmontgomery

Well-known member
Oct 14, 2019
58
Rockwall, TX
FYI
Currently there are ongoing issues with both the Pentair IntelliCenter Alexa App and Apple Watch App.
Yea, like neither are working right now.

Pentair Tech Support reports that the software dev team is aware of this fact and that they confirm that both are down right now and that they are currently working on it.
Right... :scratch: sigh...
r.
AZ, can you check on the status of Google Home integration? The website says that IntelliCenter is supposed to work with Google Home. I called and talked to tech support at one point and he didn't even realize it was on the website. He supposedly sent a note to the IntelliCenter product manager and was going to get back with me, but he never did. Was just going to see if that integration is supposed to work.

Ryan
 

MyAZPool

Gold Supporter
Jul 3, 2018
1,074
Arizona
AZ, can you check on the status of Google Home integration? The website says that IntelliCenter is supposed to work with Google Home. I called and talked to tech support at one point and he didn't even realize it was on the website. He supposedly sent a note to the IntelliCenter product manager and was going to get back with me, but he never did. Was just going to see if that integration is supposed to work.

Ryan
Hi Ryan,
I will bring it up as I am in pretty regular comms with three specific Tech Support Reps that are dedicated more to IntelliCenter issues.
Did you happen to get the name of the TS Rep? If so, please send to me on the private message side. That will help me bring up the issue. I agree he should have called you back. Some are VERY "customer-service oriented" and some not so much. I just typically deal with the level-2 guys and they are awesome. Anyway, let me know and I'll look into it.

My IntelliCenter "laundry (HIT) list" continues to grow and mostly all due to software issues.....:p
Thanks and take care...
r.
 

rmontgomery

Well-known member
Oct 14, 2019
58
Rockwall, TX
Hi Ryan,
I will bring it up as I am in pretty regular comms with three specific Tech Support Reps that are dedicated more to IntelliCenter issues.
Did you happen to get the name of the TS Rep? If so, please send to me on the private message side. That will help me bring up the issue. I agree he should have called you back. Some are VERY "customer-service oriented" and some not so much. I just typically deal with the level-2 guys and they are awesome. Anyway, let me know and I'll look into it.

My IntelliCenter "laundry (HIT) list" continues to grow and mostly all due to software issues.....:p
Thanks and take care...
r.
Unfortunately I don't have his name. It may be written down at the office, but I probably will be working from home for a while. I will double check that I didn't write it somewhere else, but chances are slim.

Ryan
 

MyAZPool

Gold Supporter
Jul 3, 2018
1,074
Arizona
@rmontgomery
Regarding your issue concerning Google Home integration.

I thought I would try a new venue in an attempt to try and "light a fire" under someone at Pentair regarding all of the IntelliCenter software issues that the Software Engineering and Software Development teams are responsible for and refuse to address "in a timely manner".


I chose to write a review on the Apple App Store IntelliCenter page. It appears that someone from the software teams do read and respond to these, so I thought I would try this route. I placed your Google Home issue here.

In addition, I have been doing some internet sleuthing and have located contact information to some of the "big dogs" in the Pentair hierarchy or chain-of-command. If this latest attempt to try and get some of these issues addressed doesn't work, I will start writing some of the executives who might have some oversight and power to get something done regarding the many software issues that these teams refuse to address.

Feel free to read my review here. It is the review (rcinaz, 03/20/2020) titled "IntelliCenter Software Issues"
Who knows if anything will come of this. I would be thrilled if they would just respond with some reasonable information and I would be very interested to see what they might have to say.
Thanks...
r.

EDIT: DUE TO THE ONGOING COVID-19 PANDEMIC, I DON'T EXPECT MUCH MOVEMENT ON THESE ISSUES AND I WILL DELAY ANY CONTINUATION IN MY EFFORTS TO TRY AND GET SOME ACTION FROM PENTAIR UNTIL WE ALL GET PAST THIS.
 
Last edited:

Turbo1Ton

Gold Supporter
Dec 26, 2019
61
NE Oklahoma
So I don't know if this has been mentioned or not, but it is something I noticed the other day. My understanding is that for all of the circuits that are controlled via a pump, the pump will defer to whichever circuit has the highest speed. If you are running a circuit that is defined by a flow rate, and not a pump speed, that is nested in with the others, it appears that the pump will only control to the pump speed. See attached.

I have a circuit set up for my in floor cleaner to run. I have it set to run @ 50GPM to ensure that the heads have enough flow, as opposed to a pump speed. When I select the spa circuit, the pump attempts to speed up to the 3450RPM setting, but then the control comes back down to the 50GPM rate.

I am not sure why this is, or if it should be considered an "issue" per se, more of just an observation and something to consider when you are scheduling. Thought I would mention it since I hadn't seen it discussed and was surprised when I noticed it.

Thanks,

Jeff
 

Attachments

MyAZPool

Gold Supporter
Jul 3, 2018
1,074
Arizona
So I don't know if this has been mentioned or not, but it is something I noticed the other day. My understanding is that for all of the circuits that are controlled via a pump, the pump will defer to whichever circuit has the highest speed. If you are running a circuit that is defined by a flow rate, and not a pump speed, that is nested in with the others, it appears that the pump will only control to the pump speed. See attached.

I have a circuit set up for my in floor cleaner to run. I have it set to run @ 50GPM to ensure that the heads have enough flow, as opposed to a pump speed. When I select the spa circuit, the pump attempts to speed up to the 3450RPM setting, but then the control comes back down to the 50GPM rate.

I am not sure why this is, or if it should be considered an "issue" per se, more of just an observation and something to consider when you are scheduling. Thought I would mention it since I hadn't seen it discussed and was surprised when I noticed it.

Thanks,

Jeff
Jeff,
Yep. I stumbled upon this about a year ago and I had to go digging to find out what was going on. Actually this is not an IntelliCenter thing. It is a "VSF thing". ;)
Check out pp15 of the INTELLIFLO® VSF Variable Speed and Flow Pump Installation and User’s Guide.
Scheduled Program Priority
When operating the pump in Schedule mode it is important
to keep each program within its own individual run time. If
program run times overlap the pump will prioritize programs
as explained below:
Schedule priorities are in descending order as follows:
Highest Flow » Lowest Flow » Highest Speed » Lowest
Speed
• When two speed OR two flow program schedules
overlap, the pump will run the higher RPM Speed or
GPM Flow regardless of program in use.

When both a speed AND flow program schedule
overlap the pump will run the flow program first.

• A manual or egg timer command takes precedent
over a running schedule. The manual or egg timer
command will operate until completed, unless the
next schedule program takes place or another
command is given.

Thanks for bringing this up and take care.
r.
 
Last edited:
  • Like
Reactions: Turbo1Ton

Poolmama!

Silver Supporter
Feb 20, 2019
92
Dallas, Tx
I haven't read every page/entry here so not sure if this is the correct place for the questions:

1) Still no resolution to the 'schedules' issue, right? Can't edit a schedule via iOS app or web client. I can edit at the panel.
2) Date and time: randomly wrong...both when I had it to automatically get day/time from the internet and then I chose Manual and it holds for a few days but then goes to some random day and time that obviously screws up my schedules.
3) Email notifications don't match the app...
a) I'll get cold water email notification saying water is below 52, but the app says the water is 62.
b) Clean and inspect cell, even after verifying cell is perfectly clean.
c) Low and Very Low Salt when I've verified the salt is 3,400 and app says salt is 3,200.
 

MyAZPool

Gold Supporter
Jul 3, 2018
1,074
Arizona
Poolmama!
1) Still no resolution to the 'schedules' issue, right? Can't edit a schedule via iOS app or web client. I can edit at the panel.
Correct. Same with me. I don't expect any resolution to the many software issues until the COVID-19 pandemic has subsided. Just a guess on my part.

2) Date and time: randomly wrong...both when I had it to automatically get day/time from the internet and then I chose Manual and it holds for a few days but then goes to some random day and time that obviously screws up my schedules.
I don't seem to be having a problem with that and don't recall that I ever have. I have always used the Internet as my clock source. Could it be that you are having internet interruptions? If not, then it sounds like it could be a Pentair IntelliCenter server issue possibly. I suggest that possibility because from what I can tell, server issues seem to be the source of many of the IntelliCenter issues these days.

3) Email notifications don't match the app...
a) I'll get cold water email notification saying water is below 52, but the app says the water is 62.
b) Clean and inspect cell, even after verifying cell is perfectly clean.
c) Low and Very Low Salt when I've verified the salt is 3,400 and app says salt is 3,200.
I agree. I too am experiencing all of those same exact issues. My salt level is good, temp is good and my cell is sparkling clean. Until some serious software modifications are made in the future, I am just ignoring these fake IntelliChlor alerts. I don't rely on the alerts. Instead, I rely on regular testing. I use the Taylor K-1766 to measure my pool salt content.
.
Also see this thread for additional info regarding the unreliability of the IntelliCenter IntelliChlor alerts.
I know how you feel. It's very frustrating. You can attempt to give Tech Support a call and see if you can get them to gen up a trouble ticket but I wouldn't be surprised during this pandemic, that they are on serious reduced staffing levels or not at work at all.

I personally have chosen to freeze all of my dealings with Pentair until this COVID-19 blows over.

Technical Support
Toll Free
(800) 831-7133, * Press 1-1-1-1-1-3 for IntelliCenter
r.
 
Last edited:

MyAZPool

Gold Supporter
Jul 3, 2018
1,074
Arizona
Hi All,
For what its worth, there is a Web Client Update (1.046 b5), dated March 30, 2020. It must have been released in just the last couple of days, as I tend to keep an eye out every few days..

Now for the bad news. From what I can tell, nothing has been improved and none of the fixes regarding the Schedules page have been implemented (see below).

Web Client – Existing schedules will not expand when clicked on which completely prohibits the ability for the user to edit an existing schedule. This issue began with the release of the latest web client update (1.044 b1 January 30, 2020) AND NOW ((1.046 b5 March 30, 2020).
Web Client – Schedule names revert to SPECIALCIRC 1, 2, 3 ETC: This occurs when a user creates a CIRCUIT GROUP and then creates a new schedule. No problem creating the new group. Then the user navigates to the SCHEDULES page > ADD PROGRAM, and then uses the pulldown to select that new CIRCUIT GROUP. Then the user configures days and times and then clicks SAVE. Once the new schedule is saved, the Circuit name in the scheduling page renames to SPECIALCIRC1, 2, 3. ETC.

In fact, if anyone can tell any improvement to the Web Client with this latest update, please share, because as of this post, I sure don't see any.
Who knows, maybe I ran this latest ops check on the schedules page before they have fully uploaded whatever to the server. I'll try later to see if any improvement.
Anyway,
Please stay safe everyone.
r.