Nodejs-poolController doesn't communicate with Pentair Pool Equipment

enjos

New member
Jun 5, 2021
3
Tucson Arizona
Hello,

Can someone please help me with the nodejs-poolController? I have not been able to successfully connect with a raspberry pi 3 or 4.

Here are the pieces have connected

Solar Touch
IntelliFLO variable speed pump
IntelliChlor IC40
Raspberry Pi 4
Industrial USB to RS485 converter

I followed the instructions and when I run npm start it will hang on this screen.

1623034518348.png

I checked the RS485 messages on USB0 and see the repeating ff00 00a5. Does this mean that it is trying to communicate with the Pentair Equipment?

1623034654634.png

When I ran npm i in the poolController directory I see a few errors and it doesn't show the post build messages that where shown in the guide.

1623035079485.png

Here is a screenshot of the dashboard.
1623036300653.png

Please advise.
 

Attachments

  • replay (2).zip
    14.7 KB · Views: 1

Candurin

Well-known member
Jun 30, 2017
296
South Jersey
Pool Size
13000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Try switching your two cables on the USB adapter at the Pi. That fixed it for me.
 

enjos

New member
Jun 5, 2021
3
Tucson Arizona
I did try to swap the connectors but no luck. It seems like there is an issue with the npm install from the poolcontroller directory.
node = v12.22.1
npm = 6.14.12
 

rstrouse

Well-known member
Jun 17, 2020
175
California
Try deleting the directory and cloning it again. According to the errors above it is not compiling the serial port. You can also try sudo npm i.
 

enjos

New member
Jun 5, 2021
3
Tucson Arizona
No luck on the deleting and cloning or sudo npm install.

I tried using nodejs-poolcontroller 6.5.1 and started to see my chlorinator and pump but it wouldn't complete the setup and the dashpanel didn't work with it.

The SolarTouch panel that I am connected to does communicate with the pump just fine.

Do I need to have a intelliCenter for this to work?

1623289576989.png
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.