Jandy LXi heater - get initial ignition, comes up to temperature, but won't re-light to maintain temp.

Sproutman

New member
Jun 9, 2020
1
Cedar Park, TX
Hey folks!

Hoping to get some clues as to what's up with an older Jandy LXi heater that's not working consistently.

Been in my house for about 5 years - pool and equipment came with the house, and was clearly a few years old at that point. Heater outdoors, but in a covered area so it's not getting rained on.

We primarily use the heater for an integrated hot tub. Heater worked fine the first couple of years, but has been flaky the last few years. Sometimes it would light and work fine, sometimes it wouldn't, sometimes it would come on once, but then not re-activate once the water temperature dropped - just flaky all around. Pool company we contracted with for service at the time could never make it work right; threw parts at it, called it "repaired" (and charged us accordingly), but the next time we'd go to use it (often weeks later), it would act up again and they wanted to bill us again.

Most recently - would light very rarely, so decided to give it a go myself. Checked resistance on the igniter; supposed to be between 40 & 75 ohms; was at 76 ohms one time, and 74 the next. Swapped it - new one has proper resistance reading, and it seemed to help; lights the first time *consistently* now. Unit comes up to temperature, but will not re-ignite; ends up timing out after 3 tries, I get my ignition fault, and three flashes on the ignition control module. When this occurs, I *am* seeing the glow through the window on the side of the unit when I've checked, so the igniter seems to still be online.

Next, I replaced the flame sensor rod; it had a fair bit of residue on it - cleaned it first; no change, so swapped it. No change in behavior with the new sensor.

Pressure sensor was replaced recently by my pool maintenance guy (as part of his attempt to resolve) before I did the above - (he still works for the old company, and has buddies who help with repairs) - it looks fine, both hoses are new - no obvious issues there.

When in the hot tub, I have a flashing LED on the local controls that goes solid once the target temperature is reached - that's working, and the remote also shows it reaching target temperature.

Subsequently, it just starts cooling down, and I see the temperature drop. If I toggle the heat off/on via the remote - no change. If I do it via the panel on the heater, and then watch the port on the side, I see the glow, get my three attempts, and then the ignition fault on the ignition control module (3 flashes of the LED).

Could it be the incoming airflow needs to be adjusted a bit, in that once the heater has been on for a while, the mixture needs to be slightly different to allow for the subsequent rounds of ignition and heating? I don't have the tools to measure the plenum pressure unfortunately (and the pool company - who built the pool and installed the equipment - always said to just "experiment"). If I close it off too much, I do get the appropriate error message, so I've kept it where they last left it, and since it's lighting that first time, I assumed it must be in an appropriate operating range.

Open to any suggestions on what to check next; kind of a pain since I can't just do testing right off the bat - gotta let it heat up, cool down, and wait for that second attempt at heating, and with the noise of the pumps, and it usually being dark out, my troubleshooting has been limited at that point. Is there a different module or sensor I should suspect/check next? I've re-seated connectors to the ignition module, looked for any corroded connectors, damaged wiring, etc, esp. since we've had a mouse get into the heater a few times - no obvious concerns.

Unit is on propane, and has a dedicated line that's for it, a 700 square foot outbuilding (with AC/heat), and a patio fireplace and grill - neither of the others are in use when this occurs, and no issues with any of them to date - and again, it's been installed and working for some time in this configuration.

tldr; Jandy LXi heater lights initially, comes up to temperature, shuts off, but won't re-light (ignition fault message). Swapping igniter allowed for consistent initial ignition, but won't re-light, though I do see the igniter glow. Swapping heat sensor made no change. Pressure sensor swapped prior to the above, hoses good, and connected securely on both ends.

Thanks much!
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
18,959
Northern NJ
@setsailsoon ideas?

but the next time we'd go to use it (often weeks later), it would act up again
Once you get your heater going run it at least once a week. Don’t let it sit idle a long time. Spiders and other creatures like to nest in it and cause problems. Run it more and it will be more reliable.

You will find links to Troubleshooting Guides in Jandy LXI Heaters - Further Reading
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
3,147
Stuart/FL
The error you are getting indicates one of the sensors in the safety loop is reporting an "unsafe" condition. It's strange you always are able to cycle through once and then always get the error when heat is called by the control system. It sounds like your module is functioning properly and probably getting the "unsafe condition" because of a corroded sensor connection or a sensor that is intermittently failing. I would try to replicate this during the day and when the failure occurs try to wiggle connections of each sensor. If that doesn't work bypass each sensor. Any of the bypass attempts that allow ignition indicate you have your culprit. Either connection or sensor is bad. It seems possible that a connection or bad sensor could both cause this behavior if the heating cycle causes the connection to change a little or causes something in the sensor to fail. The sensors involved could include the high vent gas temp, high and high-high temp limit sensor, water pressure, and fan pressure sensor. The fan pressure sensor is not as simple to bypass so do the others and lets see if they help. For the fan pressure sensor just check the connections. The fan pressure sensor is extremely reliable but in my Jxi heater connections did cause a similar problem. Did not look dirty or corroded but cleaning and reconnecting solved the problem. In my case the fix has been permanent.

I hope this helps and please keep us posted. It's helpful to us and others when we find what works.

Chris