Help please. It didnt look like this last time

mrmacdad12

Well-known member
May 19, 2012
183
Baltimore, Maryland
Just pulled the cover and this is what it looks like. The pillow deflated during the winter so I removed it. Cover and pillow only 2nd time used.

What to do first? I have the hose running. Can start pump as soon as water level rises.

Can slightly see bottom. Looks mostly to be fine sediment. There are live mosquitos. Heavy brown algea content.

Any advice I would appriciate.

Thanks
Tom
 

jblizzle

Mod Squad
TFP Expert
LifeTime Supporter
May 19, 2010
41,195
Tucson, AZ
I agree with Woody. Make sure that you fill it up and run the pump before doing any testing.
 

mrmacdad12

Well-known member
May 19, 2012
183
Baltimore, Maryland
I guess the abnormal warm winter and shotty cover caused big problems this year.

Only thing that was different this year is the skimmer was added. Guess I need to make a block off plate. The year prior I left the inlet and outlets open. But it was a lot colder of a winter...
 

mrmacdad12

Well-known member
May 19, 2012
183
Baltimore, Maryland
Yeah I do... I figured I get a little something going but ill wait. Pump almost ready to go. Little more water and the inlet is covered.

I got 3 gal of 8% bleach guess i better get 3 more. I have a box of borax so i should be good. CyA still half a bottle of granual so I think I just need some bleach.

My lil shark doesnt have a prefilter so I can either hook it up to the side wall inlet. Or I have a skimmer plate..

Maybe get a couple paint strainers for my skimmer basket to prefilter.
 
Thread starter Other Threads of Interest Forum Replies Date
U Pool Cleaners 8
DiverGirl1972 Just Getting Started 5
J Poolside Paradise 13

Other Threads of Interest