Automated Control of UltraTemp Heat Pump

ewag316

Member
Nov 14, 2021
8
Clermont, FL
Pool Size
23600
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Owner/builder project. Just got water in and equipment started up two weeks ago. Everything is working fine in manual control, and if I use my iPad everything runs perfectly EXCEPT for starting/stopping the heat pump remotely / automatically from my ScreenLogic system (iPad / iPhone). The heater WILL run and do it's job if I take it out of remote mode and operate it completely from the heater touch panel. I've written this post about 4x trying to figure the best way to convey everything I know, and all that I've done. I typically try to exhaust existing forum posts, research from others, etc before creating a new post. Though that research has helped me solve a ton of other questions, as well as things to try to solve THIS issue, I can't seem to figure the magic combination of things to solve the problem.

So I figured the best way to convey info was to use photos and notes to show what I have done, what I'm seeing, and what I'm thinking. The attached PDF is 4 pages and might be overkill, but hopefully it helps. A picture is worth a thousand words right? My hunch is that I have UltraTemp wired correctly, and menus setup correctly, and the problem is either where I have the RS-485 terminated in EasyTouch and/or I don't have EasyTouch set up correctly.

This pool was a Christmas gift to ourselves. In FL it still gets "cold" .... 45 degrees ... we can at least still enjoy the hot tub in manual mode :)

For anyone patient enough to help, thank you in advance!!!
 

Attachments

  • Heater Remote Control Troublshooting.pdf
    2.3 MB · Views: 9

rstrouse

Well-known member
Jun 17, 2020
402
California
I am pretty sure you need a thermistor or resistor between the contacts of the solar sensor. ET uses the solar heater logic to control heatpumps which requires connection for the logic in the board to work. That is the reason for the wonky configuration settings where the solar heater options get set when you choose a heat pump. If a reading from the solar sensor is not present it will not send the requisite messages over RS485 to start the heater.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
33,553
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
When you connect the UltraTemp to Pentair automation using the RS-485 data connection you need to add a solar temperature sensor in addition to the air and water temperature sensors. Solar temperature sensor could be left loose in load center. The automation system does not use the temperature reading but just looks for resistance.

A 10K resistor will work, and is less expensive, or a temperature sensor.

You can steal the air temp sensor and connect it to the solar to test it immediately until you get a resistor.

 

ewag316

Member
Nov 14, 2021
8
Clermont, FL
Pool Size
23600
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
When you connect the UltraTemp to Pentair automation using the RS-485 data connection you need to add a solar temperature sensor in addition to the air and water temperature sensors. Solar temperature sensor could be left loose in load center. The automation system does not use the temperature reading but just looks for resistance.

A 10K resistor will work, and is less expensive, or a temperature sensor.

You can steal the air temp sensor and connect it to the solar to test it immediately until you get a resistor.

Awesome... will try the air sensor as a fill in solution
 

ewag316

Member
Nov 14, 2021
8
Clermont, FL
Pool Size
23600
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I am pretty sure you need a thermistor or resistor between the contacts of the solar sensor. ET uses the solar heater logic to control heatpumps which requires connection for the logic in the board to work. That is the reason for the wonky configuration settings where the solar heater options get set when you choose a heat pump. If a reading from the solar sensor is not present it will not send the requisite messages over RS485 to start the heater.
Thanks, probably exactly what I need to know!
 

ewag316

Member
Nov 14, 2021
8
Clermont, FL
Pool Size
23600
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Moving the air temp sensor over to solar did the trick. That, and clicking H.PUMP rather than HEATER to activate the thing to "on" .....

Thanks for the help!
 

Attachments

  • Screenshot 2021-12-24 202304.jpg
    Screenshot 2021-12-24 202304.jpg
    9.8 KB · Views: 6
  • Like
Reactions: mknauss
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread