2009 Aquarite 20 issue

ThomasPNW

New member
Aug 7, 2020
2
98290
Hello new to the bored,
My dilemma, just purchased generic T5 cell mostly due to a very good price purchased. Until I found out that the cell is only compatible with firmware of 1.5 or better. Come to the understanding that circuit boards only last maybe 7 years and this board is running up to 11 years now. My gut feeling, is to purchase a new board upgrade do the firmware 1.5 instead of 1.4. Or just try to return a new cell. Comments
 

JamesW

TFP Expert
Mar 2, 2011
21,551
See if there is a jumper on the J4 pins on the main board. The J4 jumper selects the cell type. On is T-15 and off is T-5.

If the model number is a 20 (20k gallons), that usually means that it takes a t-5 cell.

What was the original cell?



 
Last edited:

ThomasPNW

New member
Aug 7, 2020
2
98290
See if there is a jumper on the J4 pins on the main board. The J4 jumper selects the cell type. On is T-15 and off is T-5.

If the model number is a 20 (20k gallons), that usually means that it takes a t-5 cell.

What was the original cell?



This is my third replacement. I went with a generic Cell 5, called Platinum Edition salt Cell 5. Unfortunately won't let me adjust the instant salt level down to the appropriate level. Stays at 4,000 or higher. Called the distributor out of Australia, and they said my aquarite 20 circuit board has firmware of 1.4. I need 1.5 or better! Just about ready to purchase the Hayward GLX PCB Rite board but reading your thread is a Chinese knockoff. Am I in trouble?
 

JamesW

TFP Expert
Mar 2, 2011
21,551
Can you show a picture of the main circuit board?

Remove the display board so that we can see the entire main board.

How are you measuring the salinity?

The system comes with a T-5 cell, so a T-5 should work.

Is the system shutting off with a high salt warning?