pump

  1. S

    New Pool Pump Motor Overheating

    I recently switched out my booster pump motor (like for like). Century 2.5 HP 230V. The existing motor was old (not sure how old because I purchased the home 1 1/2 years ago) and was blowing start capacitors. After three capacitors I went ahead and switched out the motor as it seemed the old...
  2. Fergie999

    Pump we tend keeps failing

    I have an Inground pool that is less that 1yr old. The pump and all systems worked great last year. The wet end of my pentair pump failed three weeks ago. One of the tabs broke off and the lid would no longer seal. I called the pool installer and he located a new one for me under warranty! I...
  3. B

    Pump not turning on, no sound

    I’ve had great help from this forum in the past, and want to ask for advice again. My pump stopped running. No humming, no sound at all. I confirmed with a multimeter that I have 240V running to the pump, the capacitor is good, and the wiring looks ok too. If it is jammed or bearings are bad, I...
  4. B

    Water bubble builds in pump skimmer until hardly no return pressure

    Please help!!! The pool guy said it was normal but it doesn’t look normal at all. As soon as it’s on it works great and pressure is good for about 15 minutes. Then slowly air bubbles start to form inside the pump skimmer until it becomes one big air bubble and no water movement in the pump...
  5. T

    Replacing single speed pump. What pump should I use?

    Pump died, again (replaced the motor in 2018), so this time going to replace the whole pump instead of just the motor, as 2018 was the 2nd motor I've replaced on this pump. With new regulations coming in July, glad to still have options now. Options: Variable Speed - pricey, and with my low...
  6. U

    System not circulating water

    So I had recently purchases a home with a pool and have been having flow issues consistently since opening. I tried backwashing a few times and rinsing, but nothing improved. The jets in the pool are very weak when on the filter setting but worked better when set to recirculate. Finally, I...
  7. R

    New filter, or just replace cartridge?

    10,000 gal round AGP FC: 6 CC: 0.5 CYA: ≤ 20 (Added 2 lbs. last night, still dissolving) PH: 7.5 TA: 70 Passed OCLT 5/18 Our 2 year old filter doesn't seem to be cutting it anymore. Water appears less than clear/sharp and there are silty deposits on the bottom despite vacuuming and brushing...
  8. M

    How long did your pump last before you replaced it?

    Hi everyone, I am just wondering how old your pump was before you replaced it? Did you ever fix it first before replacement? For reference we are in Ontario Canada and our pool season is only about 5 months. Our current setup is an old 1980 18x36 pool with 8ft deep end, 1.5" piping two jets...
  9. K

    Pump Not Priming on Opening

    Not sure what I'm missing. I feel like I struggled a bit last year, but eventually got it. But today it's just not happening for some reason. I've followed all the instructions I can find at various places. I've tried with the pool drain, I've tried with the shallow skimmer. I've tried with...
  10. Athena_Cleo

    Best SWG system, filter and pump for INTEX XTR Pool

    Hi, Everyone! I am new to this forum. I can't find an answer to my question. Maybe you guys will be able to help me, please ? I've ordered Ultra XTR Intex above the ground pool 18 X 52 round. I need to buy filter , pump and Saltwater system. What’s is the best compatible for Intex pool? I know...
  11. TatianaP

    Bought a home and over my head

    Hello everyone! I just bought my first home and it has an in ground pool. I have no knowledge whatsoever on pool maintenance but I’m willing to learn. The previous owners left me nothing so I have no clue what I need to do or even what I have. I know that my pool vacuum doesn’t work but I can’t...
  12. A

    Pool pump stopped priming

    About a week after opening my pool, the pump stopped priming when it turns on. I've tried a bunch of things trying to find an air leak on the suction side above ground. There is very little piping above ground before the pump. I have 1 main drain and 1 skimmer, changing to block either has zero...
  13. B

    Could I have damaged my pump?

    Today while getting ready to vacuum my pool, I mistakenly closed all three valves leading to the pump while it was running, thinking for some reason the vacuum valve was open. I quickly realized my mistake when the vacuum hose wasn't pulling any water, but the pump was dry and starved for about...
  14. P

    Above Ground Pool Filter/Pump?

    Hey y'all. I am new to this forum (first post hah!) and am having some ground leveled and putting up an above ground 16x48 round pool shortly. I know the pump it comes with is garbage (as the reviews state), so I wanted to know what is a good quality pump/filter to use for it that is not too...
  15. I

    Sand filter pressure going up really fast

    Hi ya'll Im new to this forum but I have gotten some useful information from it. I've got a problem with a customers equipment, when I first got there the pool was green, so I treated it accordingly but the pressure of the filter was going way high. After removing the valve I found out the sand...
  16. S

    Very fine dirt in pool

    We had our Pentair 1hp Superflo pump crack from the Texas winter storm and I replaced the pump with a Superflo 1.5hp pump. Ever since then I have very fine dirt in the pool. I have vacuumed twice and it always returns. Granted I didn't vacuum to waste because I thought the dirt was from high...
  17. 8

    Replacing single speed pump with dual or variable speed

    Hi all, I’m looking to replace a single speed pump that died at the end last season with either a dual speed or variable speed pump.I live in the northeast, so the pool is open for about 4 months a year and it’s not very large (9k gallons) or a very complicated setup. My pool guy recommends a...
  18. S

    Introduction of Me!

    Hi all. As a former lifeguard, I always maintained the pool on site. But maintaining your own is a whole new world. Im looking forward to having a community to help me. And I look forward to helping all of you too. Bookmarking this site! Currently I am looking to place a fence on my pool: a 15...
  19. N

    Pentair Whisperflo frozen ... found crack

    Hi, I noticed there is another post with similar situation where my Pentair Whisperflo frozen during Texas freeze and now I find some cracks on my pump. See the attached images. Im trying to apply epoxy along these cracks and am waiting for it to cure to see if that would work. I also...
  20. N

    power outage, pool freezes and possible pump replacement advise.

    Hi, I am in DFW area, temperature was below 10 degree and our power went out overnight(pump was running all the time before outage) I realized outage in the morning, i shut the pump power from breaker, i opened the drain plug of the pump strainer pot and put it back very loose so the water can...
  21. R

    Upgrading old equipment

    I'm planning to upgrade some of my older pool equipment this spring, looking for some feedback to see if i'm on the right path or if better options are available. Location: Central Indiana Use: We swim daily and like warmer water 78-82f. Pool Size: 18-38 oval inground, 4ft shallow to 10ft deep...
  22. L

    Pump/Filter Replacement

    First time post, but have really appreciated all the advice in other forums in the first year I've owned my pool. Both my filter and pump have leaks and the valves also need to be replaced. The pool is about 15k gallons and the pump is 2in pipe 35ft to 1st skimmer, 65 ft to 2nd skimmer. No...
  23. D

    Replacing pump (on a budget) basic questions

    I've got a 15k gallon in-ground pool, and I think my pump is dying. It's about 11 years old. My local pool repair person says that's about its life expectancy, and I'm noticing it's not doing a great job of pulling the water and keeping the pool clean, and I see air bubbles daily which I can't...
  24. A

    Intelliflo VS pump tripping GFCI breaker

    Hi, I've read around the forum, but I can't seem to find a similar post, so here we go... I came home to find that my pool pump was not running. Went down to check it out and found the the Pentair 220amp GFCI breaker was tripped in the control cabinet. I tried to reset it and it immediately...
  25. C

    Dead Hayward VSP

    Hey All, I came home to a dead "features" pump. Pump runs a waterfall and 6 jets in the pool. Strange part was, the CB in my house popped. Not the one on the OmniLogic panel. Hmmm. So, I've not had very good luck with Hayward pumps or Drivers. I know, join the club. I have two SP3400VSP...
  26. L

    2-speed pump only runs on low speed

    We have a brandnew Hayward Powerflo Matrix 2 speed pump installed April 2020 by a professional electrician. Everything was working fine until yesterday when I noticed that the pump won’t work on High Speed. But it works on Low Speed. I’ve checked the pump basket and nothing is blocking it. No...
  27. tmking86

    Pump amperage

    We have a new Hayward W3CC15093S XStream Above-Ground Pool Filter Pump System, 1.5 HP, rated at 15amps, single speed. It is pulling 14 amps continuously. Is this "normal"? Also, the motor is hot to the touch but has not shut off. We live in the Tampa Bay area and it is 90 degrees outside but...
  28. R

    New impeller now tripping

    Hi All I was given a summer waves/polygroup cartridge filter pump. Had it a for a month. Didn’t work great so I inspected it and it needed a new impeller. Replaced it today and boy does it move water. However, now the built in gfci trips. First I had it plugged into a protected receptacle which...
  29. J

    Real basic pool automation suggestions and pump replacement

    I have a 15,000-gallon inground pool with the following: 1 pool light that works off a switch inside the house, which is not working at the moment, I suspect needs a new bulb. Intermatic basic mechanical timer, which needs to be replaced, not keeping time and until it stopped working...
  30. X

    Hayward sp32900vsp

    I just built a brand new in ground pool for the family. Finally filled it with water today and I can't get the pump to turn on. Nothing happens. I have it setup to a hayward aquaplus, using a 240v siemens qt 15amp breaker. I have even tried just connecting it directly to the breaker instead of...