Salt Question

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
17,007
Bedford, TX
PC7,

Did you already have the flow switch replaced once ? When cells are new, those connectors are not there...

I did not notice the "missing" green wire... Is it really missing or is it just the pic??

Thanks,

Jim R.
 

poolcurious7

Bronze Supporter
Sep 20, 2018
93
Florida
I don't see a green wire going to the flow switch?

I see a green wire from the cell going into the connector, but I don't see a green wire coming out.
Yes, I know, I am not sure if that's normal or not, however when I looked online at some installation videos it seemed to match up with other set ups.
 

poolcurious7

Bronze Supporter
Sep 20, 2018
93
Florida
PC7,

Did you already have the flow switch replaced once ? When cells are new, those connectors are not there...

I did not notice the "missing" green wire... Is it really missing or is it just the pic??

Thanks,

Jim R.
Yes the flow switch was replaced a couple of days ago bc on ScreenLogic the salt level was reading as 0....and now I have this new issue...
Talking to pentair it seems like they dont even manufacture the part, the flow switch is made by a different company which is compatible...maybe thats why the missing green wire...
 

JamesW

TFP Expert
Mar 2, 2011
18,483
There's a tag on the flow switch. What is the model number of the flow switch?

You need the green wire or the temperature sensor will not work.

Who replaced the flow switch?

Is was done incorrectly.

The green wire is probably in the cable.
 

poolcurious7

Bronze Supporter
Sep 20, 2018
93
Florida
My PB.
Harwil - q-12dst-c2

I already e-mailed them and told them it needs to be replaced....so we will see what happens...
Worse case scenario, I guess they can replace the whole intellichlor.

Just to be clear, this shouldn't mess w/ the actual function of the intellchlor (i.e., producing chlorine), this is just for sensing the amount of salt/temp, etc. correct?
 

JamesW

TFP Expert
Mar 2, 2011
18,483
The IntelliChlor uses the Harwil Q-12DST-C2, which detects flow and temperature. It has an integrated 10k thermistor. There are four wires, red, black, green and white. Red and black go to the flow switch. Green and white go to the thermistor.

If the thermistor is not connected, the temperature compensation will not work.

So, the salinity will not be accurate.

As long as the cell doesn't say "Low Salt", the cell should work.

There's a green wire in the cord. So it doesn't make sense that they would not connect it.