Removing desert dust from the water mechanically

TonyJr

Well-known member
Mar 28, 2016
47
Essex, UK
Hello,

I am unable to remove a very fine dust from my pool water - it is too small for the filter to catch. What other ways can I mechanically remove it? The dust is still blowing over and this is what it is.

I was just about to buy some clarifier/flocculant, then I remembered vaguely reading on TFP that it sludges your filter. I would not like to vacuum to waste as the dust is still incoming.

Tony
 

TonyJr

Well-known member
Mar 28, 2016
47
Essex, UK
Oh gosh no! Don't even go there thinking about floc and clarifiers!
How about adding a little DE to your sand filter!

Maddie :flower:
Thank you. I will forever stay clear of floc and clarifiers. My previous and only experience with DE was a bad one - I had unknowingly bought non-heat treated DE and it made a huge mess of my pool. I am sure that I made a post about it on TFP somewhere. Luckily notes have been added to that guide since then! Ordered just now a small bag of pool DE from amazon.com - I will add it very slowly and see what happens. Delivery should be next week to the UK.

What would you suggest as an alternative method, if this goes terribly wrong? I did see about adding some kind of cellulose to the filter, but have not had a read about it yet.

Tony
 

YippeeSkippy

Mod Squad
LifeTime Supporter
Jan 17, 2012
10,295
Evans, Georgia
That looks like pollen.... if its all over cars and patio furniture, its pollen. You can't really do much but hope to filter it out and wait it out. Run the pump as much as you can and lets see if this DE helps capture it.

Maddie :flower:
 

TonyJr

Well-known member
Mar 28, 2016
47
Essex, UK
The DE arrived earlier today, successful addition to the skimmer complete with a 2 Psi increase in pressure.

Now we a new problem...
47020047-A619-4744-9886-5995CA6358DE.jpeg

When I took the pump apart to un-seize it when I reopened the previous pool, I noticed a crack on on the impeller where it joins to the motor shaft. At the time I didn't think much of it as there was low light, but now I have very low flow and this bigger mess. I am going to strip it down either tonight or tomorrow and use some Araldite 2012 to bond the shaft back to the impeller. Hopefully this will be the last problem to deal with 🙂. The green lagoon will be no problem once the pump is back in service. (The low flow was spotted just before adding the DE and occurs in bypass too).

I will post another photo after the repair + clear water.
 
Thread starter Other Threads of Interest Forum Replies Date
B Spas and Hot Tubs 0
D Everything Else 2
R Under Construction 2

Other Threads of Interest