procpojudo

In The Industry
May 12, 2021
2
Lafayette, Indiana
Hello all,

I'm a CPO at a Pool and Spa company and I recently had a customer inquire about their poor backwash pressure. The individual has an Eco-Kleer filter and pump system approximately 2 years and is now experience significant reduction in water pressure when backwashing (similar to that of a garden hose). The multiport valve is not leaking and PSI during filter setting operation is within normal range. There are no known leaks nor broken valves and the customer has checked for obstructions. We have some thoughts but I would be interested to hear what others think could be causing the backwash pressure reduction. Thanks.
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
33,851
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Assuming this was a pool recently opened from winter, I would confirm all the connection to/from the filter. Ensure hoses are connected properly and not backwards. If water pressure is fine while on filter, going to backwash shouldn't change anything unless something went bad over the winter in the MPV. We typically instruct members to make note of their pressure right after a backwash, then wait until it increases by about 25% before doing a backwash.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread