Pentair Intelliflow VS no power?

Mcecere11

Well-known member
Jun 2, 2015
74
Kingston ma
hi guys,

Need some help please!?? just got back from a work trip yesterday and found my pump display was off. I checked the obvious plug and breakers and everything seemed fine. Is there a fuse on the pump itself or what is the best way to troubleshoot? My next step was going to make sure I have power going to the unit with a multi-meter and assuming I do, what are my next steps?
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,572
Bedford, TX
11,,

The display can only be blank if the display is bad, or there is no 240 power to the pump itself..

Step one is to measure the AC input with a voltmeter. Always measure between the L1 terminal and the L2 terminal for 240 volts AC.. Never measure from L1 to ground and L2 to ground as you can get a false readings...

Assuming that you do not have 240 volts at the pump, then you will need to trace the wiring back to the power source.

Do you have a 240 volt GFCI at the equipment pad for the pump? Do you have automation? The pump is supposed to get constant AC power, but some installers have been known to wire it through the Pump/Filter relay in the automation system.

Please let us know what you find,

Jim R.
 

Abauman25

Member
Jul 17, 2016
16
Lincoln, NE
This happened to me yesterday! No display, so no power. Checked all the breakers, etc. Had our pool guy out to do electrical investigation and it magically restarted stating "system failure" after about 6 hours of being completely 'dead' for lack of other words. I witnessed mine shut off, cut power like it tripped a breaker. But in hindsight I do think it overheated...there was quite a bit of lint around the fan. Hope its that easy for you.
 

Mcecere11

Well-known member
Jun 2, 2015
74
Kingston ma
user error. didnt realize my pump was on the main panel in my basement instead of the pool shed. My intellichlor is on my pool shed breaker but the pump was tripped on the GFCI breaker in the main panel in my basement. Have been running it and seems to be fine now. When i started it up it was on manual mode so im wondering if before i left for my trip this week i forgot i had it on manual and may have overheated it? not entirely sure why it tripped but will keep an eye on it
thanks for the replies
 

Mcecere11

Well-known member
Jun 2, 2015
74
Kingston ma
Merged threads - TFP Mod
ok so noticed that my pool was cloudy when returned home from a business trip. Originally noticed that the breaker was tripped so i flipped it back on and powered the pump back on. Primed fine and was running what i thought was perfectly fine, i watched it for about an hour and didnt seem to have any issues. checked again a few hours later and the display was blank and the control panel was blank again. checked breaker and wasnt tripped, put my meter on the wiring harness and got 250v. Is it possible the whole pump is bad or can it just be the display unit?
 
Last edited by a moderator:

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,572
Bedford, TX
11,

If the display is blank and you have AC power to the pump, then most likely the display itself is bad.

Seems like I have seen threads here on replacing the display.. Try our Search function and see what pops up..

Thanks,

Jim R.
 

Mcecere11

Well-known member
Jun 2, 2015
74
Kingston ma
11,

If the display is blank and you have AC power to the pump, then most likely the display itself is bad.

Seems like I have seen threads here on replacing the display.. Try our Search function and see what pops up..

Thanks,

Jim R.
could the breaker have tripped because of a display issue? i just don't want to replace the display and then have an issue with the pump having to be replaced.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,572
Bedford, TX
11,

I would not think that a faulty display would cause the breaker to trip.. Read this whole thread...


Jim R.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread