No Pressure on Cartridge Filter

Mar 20, 2016
24
Albuquerque, NM
#1
I opened my pool and cleaned the filters for the first time on my Jandy CL580 today. I reinstalled them, opened the air release valve on the pressure gauge and started the pump. When water started coming out of the air release valve I closed the valve and checked the pressure gauge. It was reading 0 psi but I was getting water flow out of my returns. I let the pump run for about an hour at 2000 RPM and still had a 0 psi reading. My pool is only a year old so could it be a bad gauge or something else? Last year with new filters the reading was 10 psi.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
10,956
Bedford, TX
#3
mj,

The important part is getting a good flow of water back to your pool returns. As long as the flow is good, then the exact pressure is not all that important.

I agree with Jason that the gauge might be bad or plugged from inside the filter.

My point is that it is not something that has to be fixed right now.

Thanks for posting,

Jim R.
 

Divin Dave

TFP Expert
LifeTime Supporter
Oct 2, 2013
5,196
Longview, Texas
#4
Bad gauge is the most likely culprit. The plastic OEM filter gauges don't last long. If you want to replace, I would recommend one of the glycerin filled nice gauges like this one. Well worth the few dollars it costs and the quality of the thing is immaculate. The scale on the gauge lets also be able to determine the precise pressure too.
TFTestkits.net
 
OP
OP
M
Mar 20, 2016
24
Albuquerque, NM
#5
Bad gauge is the most likely culprit. The plastic OEM filter gauges don't last long. If you want to replace, I would recommend one of the glycerin filled nice gauges like this one. Well worth the few dollars it costs and the quality of the thing is immaculate. The scale on the gauge lets also be able to determine the precise pressure too.
TFTestkits.net
My gauge has the built in air release valve. Do they make a separate air release valve that a glycerin filled gauge could thread into?
 

Divin Dave

TFP Expert
LifeTime Supporter
Oct 2, 2013
5,196
Longview, Texas
#6
hummmm... looks like that might be new for Jandy. Ive never seen one like that. In looking at the parts list, the gauge is seperate from the relief valve but I have no idea of the fitting. Not enough info about the jandy gauge. The thing is pricey too it seems.

If it were my filter, I would give Inyo Pools a call and see what it might take to replace the original air release with something that's a bit less customized.
Jandy CL Series Cartridge Filter Parts - INYOPools.com


My gauge has the built in air release valve. Do they make a separate air release valve that a glycerin filled gauge could thread into?
 
Oct 22, 2013
10
Bellingham, wa
#7
I opened my pool and cleaned the filters for the first time on my Jandy CL580 today. I reinstalled them, opened the air release valve on the pressure gauge and started the pump. When water started coming out of the air release valve I closed the valve and checked the pressure gauge. It was reading 0 psi but I was getting water flow out of my returns. I let the pump run for about an hour at 2000 RPM and still had a 0 psi reading. My pool is only a year old so could it be a bad gauge or something else? Last year with new filters the reading was 10 psi.
I had that problem, fixed it by shutting it off, then removing the lid and basket and reaching into the impeller hole and removing pine needles wrapped around it.