New House, Old Pool, Can't get spa suction to work

DiscipleDavid

Member
Jun 2, 2021
19
Georgia, US.
Pool Size
26928
Surface
Plaster
Chlorine
Liquid Chlorine
Hello, thanks for all of the help you provide to new people like me. I have a pool/spa combo and on the bottom of my spa are what I assume are two suction drains. However, there are also these red/brown hard as rock scales that are there and I can't get them to break off. Also, it looks like the things at the bottom here twist, I tried a little to no avail, but didn't want to try too hard, just in case its not supposed to turn. I'm at a loss as to why the spa suction isn't working. When I turn the valves to suck and return to spa then the pump stops filling up with water.
 

Attachments

  • spa3.jpg
    spa3.jpg
    94 KB · Views: 8
  • spa2.jpg
    spa2.jpg
    89.3 KB · Views: 8
  • spa1.jpg
    spa1.jpg
    101.4 KB · Views: 8
Last edited:

DiscipleDavid

Member
Jun 2, 2021
19
Georgia, US.
Pool Size
26928
Surface
Plaster
Chlorine
Liquid Chlorine
It looks like some kind of plug in the drain. Can you loosen them and pull them out?
Thank you, they were definitely plugs and now the spa has a suction ability! I was also able to break apart the red scales and vacuum much of it up. I checked with two types of strips and with the pool store. I was surprised to see that it wasn't iron, copper, or calcium. I'm at a complete loss. It's mostly clean now though so I'm happy to report things are looking good. I appreciate your confirmation on the plugs.