Laars Lite Teledyne Heater shuts off randomly

Andy_B

New member
Apr 16, 2020
2
Washington - Seattle Area
My Laars Lite Teledyne Laars model LLD natural gas heater seems to be running normally at some times. The pilot starts and it runs for a decent 8 minutes and then suddenly shuts off. My guess is that one of the sensors is automatically shutting it off, but the water flow is fine and there does not seem to be any outstanding issues. Any help would be greatly appreciated!
 

Andy_B

New member
Apr 16, 2020
2
Washington - Seattle Area
No, the one I have is an LLD, and I have tested the methods with the manual I found online. However I found that the 24v transformer seems to have an issue. It consistently running at only 3-5v and when the heater shuts off, the transformer does too. I hope replacing the transformer may fix it?
 

BillBurger

New member
Apr 22, 2020
1
California
No, the one I have is an LLD, and I have tested the methods with the manual I found online. However I found that the 24v transformer seems to have an issue. It consistently running at only 3-5v and when the heater shuts off, the transformer does too. I hope replacing the transformer may fix it?

If you are measuring voltage at the transformer secondary it should always read (about) 24V.

After the transformer there is a string of permissives that have to be satisfied before the ignition controller will start it's cycle. After those permissives make up you should measure about 24V at the "TH" terminal on the controller. This is the call for heat. If water pressure, the fuse or any one of the other steps in the permissive string is open then the ignition cycle won't start.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.