Instapark Betta review

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
Actually, my bad. It was also in my manual, as a "stickie" over some previous text.
Huh! Mine doesn’t have that in the manual. That’s really good to know though as that might have been what damaged the other ones I had. I will charge mine in the pool from now on. Also mine will also sometimes randomly throw the default code of blinking red and blue. I can either reset it and it’s fine or just leave it and after 20 minutes it resets itself.
 
  • Like
Reactions: DanF

DanF

Silver Supporter
Mar 17, 2019
422
Chandler, AZ
Pool Size
12500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Is there any rhyme or reason as to why the unit stops moving and the alternating red and blue lights flash? The Betta was working fine, I went inside the house, and 10 minutes later it's stopped and flashing the code. I can't afford to watch it 24/7, but when it works it works well.

Is this something worth calling Instapark about?
 

maggiesfan

Gold Supporter
Jan 1, 2017
40
Tucson Arizona
Is there any rhyme or reason as to why the unit stops moving and the alternating red and blue lights flash? The Betta was working fine, I went inside the house, and 10 minutes later it's stopped and flashing the code. I can't afford to watch it 24/7, but when it works it works well.

Is this something worth calling Instapark about?
Mine does that also, I just leave it and it continues on its merry way after 20 minutes.
 
  • Like
Reactions: DanF

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
Is there any rhyme or reason as to why the unit stops moving and the alternating red and blue lights flash? The Betta was working fine, I went inside the house, and 10 minutes later it's stopped and flashing the code. I can't afford to watch it 24/7, but when it works it works well.

Is this something worth calling Instapark about?
It’s supposed to be a fault code. If the propellors or prop gets jammed or if it gets stuck or something like that. I noticed that sometimes mine will try and swim straight into the current and just kinda stalls in the middle of the pool. Sometimes it turns around and sometimes it keeps trying to move straight at the return until it throws the red and blue blinking lights. It will stay in that mode for 20 minutes or if you turn it off and on again. This is one of the reasons I would like to have the ability to update its firmware. I have only seen my new one do this a handful of times. Right now I’m not worried about it because so far it just means it’s going to take a 20 minute break every once in a while. Otherwise this one is fine so far. If it starts doing it all the time then I would call Instapark.
 
  • Like
Reactions: DanF

DanF

Silver Supporter
Mar 17, 2019
422
Chandler, AZ
Pool Size
12500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Now that you mention the typical causes for the fault codes, I noticed that mine is more likely to fault whenever I have the pump on high speed.
 
  • Like
Reactions: Orion7319

stormook

Active member
Mar 22, 2021
32
Ramona, CA
Pool Size
18600
Surface
Plaster
It’s supposed to be a fault code. If the propellors or prop gets jammed or if it gets stuck or something like that. I noticed that sometimes mine will try and swim straight into the current and just kinda stalls in the middle of the pool. Sometimes it turns around and sometimes it keeps trying to move straight at the return until it throws the red and blue blinking lights. It will stay in that mode for 20 minutes or if you turn it off and on again. This is one of the reasons I would like to have the ability to update its firmware. I have only seen my new one do this a handful of times. Right now I’m not worried about it because so far it just means it’s going to take a 20 minute break every once in a while. Otherwise this one is fine so far. If it starts doing it all the time then I would call Instapark.
For Orion & Dan. Today my five week old latest model Betta stopped moving but the paddle wheel kept turning and the lights were flashing blue and red. While this was happening I attempted to move the propellers and found both of the motors binding. I then turned the thing off and checked the motors, the propellers could be turned freely. I turned it back on after about a 1/2 minute and it ran for 3 seconds and shut off with flashing blue and red lights. I figured it had bought it once again. I left it on and checked it about 30 minutes later and it was working again. As a side note I had begun to think the flashing red and blue lights with the unit not moving indicated it was charging, I have noticed that happening since I received the latest Betta but have never seen just the red lights flash which they say indicates charging. The same problem I described above happened about three weeks ago but when I turned it off and back on that time it started working properly right away. If it wasn't for the fact that the paddle wheel kept turning while the drive motors were off I would probably have thought it was in its charging or rest mode again.
 
  • Like
Reactions: DanF

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
For Orion & Dan. Today my five week old latest model Betta stopped moving but the paddle wheel kept turning and the lights were flashing blue and red. While this was happening I attempted to move the propellers and found both of the motors binding. I then turned the thing off and checked the motors, the propellers could be turned freely. I turned it back on after about a 1/2 minute and it ran for 3 seconds and shut off with flashing blue and red lights. I figured it had bought it once again. I left it on and checked it about 30 minutes later and it was working again. As a side note I had begun to think the flashing red and blue lights with the unit not moving indicated it was charging, I have noticed that happening since I received the latest Betta but have never seen just the red lights flash which they say indicates charging. The same problem I described above happened about three weeks ago but when I turned it off and back on that time it started working properly right away. If it wasn't for the fact that the paddle wheel kept turning while the drive motors were off I would probably have thought it was in its charging or rest mode again.
We had several days of rain this week and mine went into the red charging mode several times. I have no idea why the propellors would lock up like that. It could be a problem with the prop motors or it could be a problem with its computer simply stopping the propellors for no reason. I do wonder if that’s normal behavior while it’s in fault mode.
 
  • Like
Reactions: DanF

stormook

Active member
Mar 22, 2021
32
Ramona, CA
Pool Size
18600
Surface
Plaster
We had several days of rain this week and mine went into the red charging mode several times. I have no idea why the propellors would lock up like that. It could be a problem with the prop motors or it could be a problem with its computer simply stopping the propellors for no reason. I do wonder if that’s normal behavior while it’s in fault mode.
Today the same problem occured as yesterday, props off, paddle wheel operating, motors magnetically seized (one real tight and the other slightly tight, though I could force turn them by hand. I let it stay that way for over 2 1/2 hours and no change. I finally turned it off and back on and it began running properly again. This time I called Instapark. They are sending me another new one. The problems continue unfortunately.
 

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
Today the same problem occured as yesterday, props off, paddle wheel operating, motors magnetically seized (one real tight and the other slightly tight, though I could force turn them by hand. I let it stay that way for over 2 1/2 hours and no change. I finally turned it off and back on and it began running properly again. This time I called Instapark. They are sending me another new one. The problems continue unfortunately.
That’s not encouraging news! Mine went into the fault mode this morning again for no apparent reason. It wasn’t in a current or anything, so I’m not sure why it did it.
 

stormook

Active member
Mar 22, 2021
32
Ramona, CA
Pool Size
18600
Surface
Plaster
That’s not encouraging news! Mine went into the fault mode this morning again for no apparent reason. It wasn’t in a current or anything, so I’m not sure why it did it.
This morning mine was not operating again and was flashing blue and red, the props could be turned easily. Thinking it might be charging I left it alone for a couple of hours. When I checked again it was still not running so I turned it off and back on and it began running. for maybe two hours or so. It then stopped with the paddle wheel still going and was flashing red and blue. This time the opposite motor from yesterdays problem was magnetically seized and the other motor could be easily turned. Again I turned it off and back on and it started operating again. It is kind of looking like this thing is good for 5-6 weeks and then the major problems start. At least that seems to be my timeframe for the beginning of the end. I hope yours hangs in there.
I am looking forward to reviews on the Ariel, but that is going to take a few months
 

Enjoying this content?

Support TFP with a donation.

Give Support

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
This morning mine was not operating again and was flashing blue and red, the props could be turned easily. Thinking it might be charging I left it alone for a couple of hours. When I checked again it was still not running so I turned it off and back on and it began running. for maybe two hours or so. It then stopped with the paddle wheel still going and was flashing red and blue. This time the opposite motor from yesterdays problem was magnetically seized and the other motor could be easily turned. Again I turned it off and back on and it started operating again. It is kind of looking like this thing is good for 5-6 weeks and then the major problems start. At least that seems to be my timeframe for the beginning of the end. I hope yours hangs in there.
I am looking forward to reviews on the Ariel, but that is going to take a few months
Hopefully they will get all the issues sorted. At this point I’m not sure if the issues are design flaws or if it’s simply hit or miss if you get a good one or not. My latest one been doing fine for the most part so far.

EDIT: Looking at the Ariel thread those seem to be having issues as well. I wish someone would review the skim devil.
 

Nealvaughab

New member
Jul 27, 2021
1
Chandler AZ
First time poster ^^^

I thought I'd chime in with my experience. I bought the Betta about 10 weeks ago off Amazon. After about 4 days I kept getting the red and blue error lights. No rhyme or reason, so I returned it and got a new one Direct from Amazon. That lasted about 6-7 weeks, when I began to notice the error stops every day or two. After looking at it, it was apparent one propeller was not freely rotating. I could unscrew it, clean it, and it would work for a day or two, but it would eventually error again. So Instapark replaced it, hassle free. The 3rd unit just stating having issues this week after working flawlessly for the last 2 weeks. No error stops, but it's stopped being "intelligent". It doesn't avoid walls, and will continue to push into the wall once it hits it. It will keep doing this for 5 minutes, reverse , and hit another wall. This is an anomaly - my first two units performed flawlessly in this regard. Going to contact Inatapark again.

When it works - this thing is a dream. What used to take me 10+ minutes by hand every day, this thing does automatically and it does a better job picking up the fine particles. I live in a rental and although the landlord provides pool service it's an old pool and the built in skimmer/cleaner isn't that great.

All 3 devices were newer revisions with thr small red power button. Happy with battery life in sun filled Phoenix. But can I recommend this? No, not After 3 units (soon to be 4) and seeing so many others with similar issues. I might try to resell the replacement, not confident in the ability for this to last past a year.
 

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
might try to resell the replacement, not confident in the ability for this to last past a year.
The good news is that if you ask for a replacement, instapark told me the 1 year warranty restarts when you receive the replacement.
 

stormook

Active member
Mar 22, 2021
32
Ramona, CA
Pool Size
18600
Surface
Plaster
First time poster ^^^

I thought I'd chime in with my experience. I bought the Betta about 10 weeks ago off Amazon. After about 4 days I kept getting the red and blue error lights. No rhyme or reason, so I returned it and got a new one Direct from Amazon. That lasted about 6-7 weeks, when I began to notice the error stops every day or two. After looking at it, it was apparent one propeller was not freely rotating. I could unscrew it, clean it, and it would work for a day or two, but it would eventually error again. So Instapark replaced it, hassle free. The 3rd unit just stating having issues this week after working flawlessly for the last 2 weeks. No error stops, but it's stopped being "intelligent". It doesn't avoid walls, and will continue to push into the wall once it hits it. It will keep doing this for 5 minutes, reverse , and hit another wall. This is an anomaly - my first two units performed flawlessly in this regard. Going to contact Inatapark again.

When it works - this thing is a dream. What used to take me 10+ minutes by hand every day, this thing does automatically and it does a better job picking up the fine particles. I live in a rental and although the landlord provides pool service it's an old pool and the built in skimmer/cleaner isn't that great.

All 3 devices were newer revisions with thr small red power button. Happy with battery life in sun filled Phoenix. But can I recommend this? No, not After 3 units (soon to be 4) and seeing so many others with similar issues. I might try to resell the replacement, not confident in the ability for this to last past a year.
Hi Neal. Sounds like my story. If your next one fails you might ask Instapark for a refund, their customer service is phenomenal. I just received my fourth brand new one today (originally purchased in Feb. 2021). It was missing two screws at the back on the bottom, I replaced them with screws from the one I am returning, no big deal, but. I did notice when I turned the defective one over that there was white hard material between the propellers and the motor body, like something had melted, come out of the motor and then solidified. The propellers would turn but you could feel a slight restriction. At other times with this five week old unit the motor or motors would magnetically seize and the unit would go into a fault mode. Also for the past three weeks it has stopped operating often and flashes a slow blue or blue and red, sometimes it would re-start by itself and other times I had to turn it off and back on. Unfortunately the Betta is still a work in progress. I do not know how long Instapark will continue to replace them. As you said, when they work they are great, but we do not know from one day to the next whether it will be working.
 
  • Like
Reactions: DanF and Orion7319

stormook

Active member
Mar 22, 2021
32
Ramona, CA
Pool Size
18600
Surface
Plaster
To keep everyone updated. The Betta I received on Wednesday failed today. The paddle wheel is operating but the propellers are not turning, one motor can be turned easily with my finger but the other motor is seized (hard to turn with my finger). This is the same thing that has been happening to the other ones. I called Instapark and as usual Vivian was as sweet as can be and said she would send another one out right away. We talked for awhile and I said this is costing them a fortune in shipping charges and she said she just wants the customer to be happy and said if it breaks they will replace it, period. She did ask if I wanted a refund, which I declined since it does such good work, when it works. She said she complains to the factory about the problems and version 3 will probably be coming out in March, 2022.
 

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
To keep everyone updated. The Betta I received on Wednesday failed today. The paddle wheel is operating but the propellers are not turning, one motor can be turned easily with my finger but the other motor is seized (hard to turn with my finger). This is the same thing that has been happening to the other ones. I called Instapark and as usual Vivian was as sweet as can be and said she would send another one out right away. We talked for awhile and I said this is costing them a fortune in shipping charges and she said she just wants the customer to be happy and said if it breaks they will replace it, period. She did ask if I wanted a refund, which I declined since it does such good work, when it works. She said she complains to the factory about the problems and version 3 will probably be coming out in March, 2022.
Vivian is awesome!!! I do think they need to switch factories, and it gets frustrating when the things break. However as long as the warranty resets on each replacement and as long as they stay in business, what’s to complain about really.
 

stormook

Active member
Mar 22, 2021
32
Ramona, CA
Pool Size
18600
Surface
Plaster
Vivian is awesome!!! I do think they need to switch factories, and it gets frustrating when the things break. However as long as the warranty resets on each replacement and as long as they stay in business, what’s to complain about really.
I agree, I am just getting tired of visiting UPS so often to return the defective unit. I have a new update. Early this morning my latest Betta starting going in circles, one motor had stopped. I lifted it slightly out of the water and the motor restarted. The blue lights were flashing normally during the circling. When it started going straight again it began to hit the walls rather than avoid them but after a few minutes its brain started working again and it ran properly. This particular Betta is breaking down faster than any of the others. When I received it (Wednesday) it appeared brand new with a note that it was charged, it even had some water droplets on it indicating that it was probably charged in the water. Two screws from the lower rear panel were missing so either it came from the factory that way or it had been worked on at the Santa Fe Springs center. Since they have probably gotten hundreds if not thousands of these back I imagine they have a lot of spare parts to work with so who knows exactly how "new" the new units are. I am expecting my next one Wednesday or Thursday.
 

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
I agree, I am just getting tired of visiting UPS so often to return the defective unit. I have a new update. Early this morning my latest Betta starting going in circles, one motor had stopped. I lifted it slightly out of the water and the motor restarted. The blue lights were flashing normally during the circling. When it started going straight again it began to hit the walls rather than avoid them but after a few minutes its brain started working again and it ran properly. This particular Betta is breaking down faster than any of the others. When I received it (Wednesday) it appeared brand new with a note that it was charged, it even had some water droplets on it indicating that it was probably charged in the water. Two screws from the lower rear panel were missing so either it came from the factory that way or it had been worked on at the Santa Fe Springs center. Since they have probably gotten hundreds if not thousands of these back I imagine they have a lot of spare parts to work with so who knows exactly how "new" the new units are. I am expecting my next one Wednesday or Thursday.
Lol! Good luck on what number is this one for you, 9?? I lost count. All I know is mine is still working fine. It’s all hit or miss.
 

DanF

Silver Supporter
Mar 17, 2019
422
Chandler, AZ
Pool Size
12500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
I haven't had to send mine back yet, but what's the process if I do? Who pays for shipping, and do I need to get a box?
 

Orion7319

Well-known member
Jul 1, 2020
555
Rock Hill, South Carolina
Pool Size
19775
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
I haven't had to send mine back yet, but what's the process if I do? Who pays for shipping, and do I need to get a box?
Call the number that’s on the inside of the betta or email them. Someone named Vivian will answer the phone or respond to the email. If you ordered it on Amazon you need to give her the order # and date you ordered it. She will ask if you want to ship yours back for repair or if you want to be sent a new one. Ask for the new one. She will ship it to you usually that day. When you get the new one she sends a return UPS label. Pack up the broken one in the box the new one came in, slap on the return label she sent and take it to your nearest UPS store.

 
  • Like
Reactions: DanF

Enjoying this content?

Support TFP with a donation.

Give Support