Guess what I found in the mail today!

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
16,214
Tucson, AZ
You might also consider adding a healthy dollop of dielectric grease on those electrical line connections and ground after you’ve tightened down the lug. Dielectric grease is a good way to prevent moisture from getting on those connections and causing corrosion. As for the digital connections, just keep everything tight and short with as little exposed metal as possible. If you can put an easily removable enclosure over the pump without obstructing airflow, then that will mitigate water intrusion a lot.
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
2,074
Stuart/FL
You might also consider adding a healthy dollop of dielectric grease on those electrical line connections and ground after you’ve tightened down the lug. Dielectric grease is a good way to prevent moisture from getting on those connections and causing corrosion. As for the digital connections, just keep everything tight and short with as little exposed metal as possible. If you can put an easily removable enclosure over the pump without obstructing airflow, then that will mitigate water intrusion a lot.
Great ideas Matt, thanks. In my prior life, when I had large carbon steel vessels shipped overseas I used Volatile Corrosion Inhibitor (VCI) granules inside them. I've shipped from Houston all the way to the S China Sea and this worked great. Thinking about a teaspoon full in the bottom along with the dielectric grease on the connections. Any thoughts on this?

Chris
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
2,074
Stuart/FL
i am following this thread closely. my 2 speed whisperflow just lost its low speed. Dang snake. this motor is not that much more than a replacement 2 speed motor. i really am surprised about the lack of user info on this motor

beers :cheers:
S,

@mknauss mentioned them in several posts so I started looking at them. I'd really much prefer a full-featured 3 hp Pentair but that's out of my price range for now. Considering the $400 price tag, I'm really impressed so far.

Chris
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
16,214
Tucson, AZ
Great ideas Matt, thanks. In my prior life, when I had large carbon steel vessels shipped overseas I used Volatile Corrosion Inhibitor (VCI) granules inside them. I've shipped from Houston all the way to the S China Sea and this worked great. Thinking about a teaspoon full in the bottom along with the dielectric grease on the connections. Any thoughts on this?

Chris
Meh. Seems like overkill. Throw a few silica gel desiccant packets in there and call it a day.
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
2,074
Stuart/FL
do you plan on upgrading to the vlink?

beers :cheers:
S,

No, I already have the pump on my Intellicenter automation. I'll add digital inputs from my solar valve actuator to switch to high when the bypass valve closes so I switch to high speed to get good flow through the solar panels on the roof. Rest of the run time I'll be at 1600 rpm. Seems to be plenty to run the swg and the gas heater.

Even if I didn't have automation I don't think I'd mess with the vlink. Seems like the internal timer is sufficient and I could still use the valve signal to switch to high speed.

Chris
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
16,214
Tucson, AZ
All of this seems like overkill. If water gets in there that easily then isn't there a problem with the design? What does the warranty say about it?
You say overkill, I say “perpetual motion”.... I’ll figure it out yet....:geek: ... I just need a few more hamsters🐹

 

JamesW

TFP Expert
Mar 2, 2011
17,325
All of this seems like overkill. If water gets in there that easily then isn't there a problem with the design? What does the warranty say about it?
In my opinion, it is a defective design. They know about the problem.

The manufacturer will cover it if it fails within the warranty period.

Even if they replace the motor, you still lose with all the time and labor it takes to replace the motor.
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
2,074
Stuart/FL
Got my Century V-Green 1.65 VS drive installed today. Here are my thoughts so far:
  • Overall quality seems pretty decent although I'm concerned that others have mentioned water leaking into the wire connections compartment.
  • Connection compartment is a cast aluminum well in the housing and there's a cast cover with a rubber gasket. Glad it's not a cheapo plastic cover.
  • It mated up perfectly to my Jandy FHPM 1.0-2 2-speed pump with no problems at all. I did use the included foam pad to fill the space between the original motor and the mounting support.
  • The motor was shipped with custom molded foam sandwich support. I was a little concerned about shipping damage potential. This turned out to be unfounded. In fact I used 1/2 of the foam to hold the motor when I installed the pump parts to the front.
  • The back cover has a hole in it for convenient use of a 5/16" hex key to tighten the impeller. No need to remove the cover. Nice!
  • For +/- $400 you get pretty sophisticated control options.
    • Internal timer with up to 3 speeds from 600 - 3450 rpm in 50 rpm increments​
    • RS 485​
    • Digital inputs​
  • There are 2 standard 1/2" conduit taps for wiring. One of them is pretty close to the bonding lug connection but not too hard to work around. I think it's nice to have 2 connectors. I can use one for the high voltage power wires and the other for the low voltage signal wires.​
  • I hooked up using my Intellicenter control for the pump/SWG. Plan to hook up digital inputs later.​
  • If you're used to a single speed or 2-speed motor the first thing you notice is how quiet this is even at top speed.​
  • Instructions for setting the speeds are very straight-forward, printed on the inside of the controller cover and easy to set up. There's also stop and override functions on the local panel.​
So far I'm pretty pleased. Just need to overcome the leak potential which shouldn't be all that hard. I'll update again after I get it fully automated with the digital inputs.

*** EDIT*** photo's and comments added below.

Chris

Nice access to the shaft with the hole in the center of the rear housing.

1578279847745.png

Plenty of room for the wiring connections. Very easy to understand panel.
1578279750891.png

Foam padding included in the box was a very handy support during assembly
1578279692815.png
 
Last edited:

Katodude

Silver Supporter
Aug 22, 2017
570
West Palm Beach/Florida
So how do you plan on controlling this with your automation? It looks like the digital input connections allow you to choose from 3 pre programmed speeds? Is that the case. Can you also turn the pump on and off with that control?
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
2,074
Stuart/FL
So how do you plan on controlling this with your automation? It looks like the digital input connections allow you to choose from 3 pre programmed speeds? Is that the case. Can you also turn the pump on and off with that control?
Kato,

Yes I am starting my pump with the same relay that I used for the old pump. That relay also provides line power to my swg relay so I can't accidentally power the swg with no pump running. I plan to control with the default speed at 1600 rpm on "step 3". Digital inputs override the internal timer which I will run for 24 hrs on "step 3". "step 1" will be set to 3300 rpm. The digital inputs can be up to 30 vac which is perfect for the valve signal that comes out of the controller. Valves us two 24 vac signals to power the motor. One opens it the other closes it. I will splice the "close" signal from the controller and connect it to "step 1". This way, anytime my solar is called for I will be at high speed so I can have turbulent flow through the tubes for max heat transfer. Any time the controller is not calling for heat the motor will revert to "step 3" 1600 rpm which I have tested and proved it is sufficient for the gas heater and the chlorinator. I may drop this speed further as I learn more about minimums for the heater and chlorinator.

At the moment, my total run time for the pump is driven by the time to circulate long enough for good skimming. This only takes about 4 hours. Chlorination is accomplished with 3 hrs or less run time at 40% power.

I hope this helps.

Chris
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
2,074
Stuart/FL
Yeah I know... I'm gonna see if I can get her to understand how humiliating this is. I already tried the "I'm the boss - GOT IT?" approach. Didn't work, in fact I'm still paying for that comment.
 

proavia

LifeTime Supporter
TFP Guide
Feb 6, 2015
1,673
Chandler AZ
You could always tell her that she needs to maintain the pool herself if you can't choose the pump you want. May be better to have an alternate place to sleep before you bring that up though. :eek::laughblue:
 

RMcGirr83

Gold Supporter
Nov 19, 2018
537
Tuscola, TX
The screw that holds the plate on has a rubber gasket...at least mine does. Checked it the other day and there wasn't a drop of water in it. Granted we only get ~20 inches or so of rain per year though.
 

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
2,074
Stuart/FL
Rich,

Thanks much, is the rubber gasket inside or outside the cover? I don't see one on mine. I plan to seal from the outside with a piece of weather proof tape while I build a PVC pipe frame and Sunbrella tent.

Chris