Explosion near the SWG

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
17,965
Bedford, TX
G,

Your pool guy is an idiot.. ? A cell's power supply should never get power when the pump is off..

Is your SWCG standalone or is it part of an automation system, such as an EasyTouch?

What kind of pump do you have, Single speed, 2-speed, or VS speed??

Thanks,

Jim R.
 

PoolGate

Gold Supporter
TFP Guide
Jun 7, 2017
4,694
Damascus, MD
Was the pool guy independent or part of a larger store/service? If he set it up like that, I would suggest he is liable for the damages. Consult an attorney perhaps?
 

Spookie

Silver Supporter
Dec 20, 2014
72
Highland, CA
When my pump is off, my ic60 displays a red light next to “flow” and the lights for the salt level are flashing “green” next to good and flashing “red” next to low.

Is this the issue discussed here?

If so, then I’ll do the necessary precautions. Just wanted to make sure before I take care of it. Thanks,
Mike
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
29,926
Laughlin, NV
Your SWCG is powered with the pump not running. That needs to be fixed -- and you have an Intellicenter so that should be controlling this. The SWCG needs to controlled by the Intellicenter.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
17,965
Bedford, TX
When my pump is off, my ic60 displays a red light next to “flow” and the lights for the salt level are flashing “green” next to good and flashing “red” next to low.

Is this the issue discussed here?

If so, then I’ll do the necessary precautions. Just wanted to make sure before I take care of it. Thanks,
Mike
Mike,

The power to the SWCG's transformer MUST be wired through the Pump/Filter relay.. This is a requirement, not an option. When the pump is off all power must be removed from the cell's power supply/transformer..

Who wired your system???

Thanks,

Jim R.
 

Spookie

Silver Supporter
Dec 20, 2014
72
Highland, CA
Thanks so much! The builder installed it. I currently control my SWG output through my intellicenter. The SWG is connected to my IntelliPH. The IntelliPH is connected to the intellicenter. Do I just need to have the builder connect the IntelliPH to the pump/filter relay and then problem solved??
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
17,965
Bedford, TX
Mike,

If your IntelliCenter has the built-in transformer for the IntelliChlor, it MUST be wired to the pump filter relay, so that that the transfomer does not get power unless the pump is running. If you have the IpH, it means that neither gets power unless the pump is running.

Thanks,

Jim R.
 

Crabcruncher

Member
May 9, 2018
12
Panama city beach Fl.
My pool builder had his electrician wire my intelliclor hot all the time. After reading the Pentair literature for the swg, I switched the power supply feed to the filter pump relay, ….it also stopped that annoying flashing lights. lol.
I guess the electricians know better until they learn better.