Pool was clean last night. Woke up and dirt is back.

mrdorkdar

Well-known member
Nov 23, 2017
45
Lake Forest, CA
My robotic aquabot pool rover turbo was doing a pretty good job of cleaning the pool yesterday. It had a bunch of fine dirt from top soil we backfilled the pool with at the bottom. The robot got most of it as we went to bed. Woke up this morning and the top soil is all back all over the bottom of the pool like it never got vacuumed. What am I missing?!
 

Oly

Gold Supporter
Jun 28, 2017
1,128
Fresno, CA
Could be several things here.
Do you have water test data? It could be algae.
Having a quality test kit and being able to test your pool water at home is key. Test Kits Compared
If it is not algae but dirt then perhaps some was on the surface or suspended and made it to the bottom as it settled.
Any possibility more dirt was introduced by wind overnight?
Add some information about your pool and test kit in your signature to assist the helpers.
 

mrdorkdar

Well-known member
Nov 23, 2017
45
Lake Forest, CA
Can’t be algae, the water is literally brand new and we haven’t even been in it yet. No wind last night and that couldn’t be it. There was no dirt on the top of the surface. So still no clue.
 

mrdorkdar

Well-known member
Nov 23, 2017
45
Lake Forest, CA
Oly it’s dirt. I saw it happen when we were backfilling. It’s nothing to do with the water. For some reason it’s not staying in the vacuum when it’s done.
 

pookiesunshine

Gold Supporter
May 12, 2016
523
Cincinnati, OH
check your filter type on the robot cleaner; i'm guessing it might be too coarse. my robot came with coarse and fine filters. i'm thinking maybe a lot of the dirt is bypassing the robot filter and resettling later.