Pentair Mastertemp fails after it rains

avolfson

New member
Jul 11, 2020
3
NJ
Hi all, I know this has been discussed in past, but I don't see a resolution in any of the previous posts.

My 6 year old Pentair MasterTemp 400HD does not heat after it rains. Blower turns on, heater kicks on and starts working but then shuts off after a few seconds. It then does this 2 more times and just shuts off. Service light goes on. None of the lights behind the panel are lit (no error code and no specific component fault).... Any advice? Thank you.
 

avolfson

New member
Jul 11, 2020
3
NJ
Thanks. I kept doing this for about 20 minutes and eventually it stayed on. I wonder if some part somewhere gets wet and senses what it should't. Will look at you suggestion. Thanks again.
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
17,687
Tucson, AZ
Pool Size
16000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I tested my flame sense current on the Fenwal and it would barely get to the minimum 2uA. Then I added the additional grounding wire as explained in that Wiki and the flame sense current immediately went back to the normal operating value. Some people get mice and vermin making nests in there and destroying wires, etc. So if you can test your flame sense current when it’s trying to fire, that will be a good indication of a bad ground.
 

avolfson

New member
Jul 11, 2020
3
NJ
Will do. (may be will just add another grounding wire anyway) .... just ordered the mouse kit from km based on that Wiki. Thanks again.
 
  • Like
Reactions: JoyfulNoise
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.