LCD Display not showing anything, but getting power?

badaboom423

Active member
Jul 9, 2020
25
Apex, NC
Opened the pool and the LCD display does not display anything. It is getting power, since I see the backlight in the display is on, but it won't show any letters. I can change filter speed using the buttons, but I can't navigate the menus and set salt cell percentages or schedule or anything like that. Any ideas on what I could try before bringing some pool company in to take a look?
 

Attachments

  • 20210422_133320.jpg
    20210422_133320.jpg
    434.4 KB · Views: 2

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
26,240
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
You can open up the panel and remove the board and look for burnt components and burnt solder joints on the back of the board.

You can see pics of burnt boards in Hayward Aquarite SWG - Further Reading although you have a ProLogic system.

You may have a problem with the display board or the main board.

If you are not comfortable taking it apart then call for service.

@JamesW
 

badaboom423

Active member
Jul 9, 2020
25
Apex, NC
You can open up the panel and remove the board and look for burnt components and burnt solder joints on the back of the board.

You can see pics of burnt boards in Hayward Aquarite SWG - Further Reading although you have a ProLogic system.

You may have a problem with the display board or the main board.

If you are not comfortable taking it apart then call for service.

@JamesW
So I might have to replace the entire board, even if everything else is working except the display?
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.