Intex Krystal Clear Sand Filter Pump for Above Ground Pools, 16-inch, 110-120V with GFCI six way valve stuck

swimcat

Well-known member
Aug 18, 2012
67
Bethpage (Long Island), NY
Hi, I absent-mindedly forgot to rinse after a long backwash and, when I returned the valve to filter, I got a lot of sand in my pool. Also, the six way valve got stuck & I can't budge it at all. I tried to unscrew the top from it so I can do a thorough cleaning but I can't separate the top from the lower piece of the valve part. My camera is not working at the moment but, if necessary, I can take a picture tomorrow. Does anybody know the problem I"m having without a picture? If so, any suggestion? My neighbor suggested wd40 or another lubricant but I'm reluctant to spray much of that on the filter. Thanks.
 

swimcat

Well-known member
Aug 18, 2012
67
Bethpage (Long Island), NY
Cat, did you ever manage to get your multiport valve issue resolved?
Hi, Splash, Sorry, for the delay in responding. Hurt back last week so was offline for a bit. Yes, last weekend, I, finally, found a pool store (Sun Tek) that helped me open it. I praise that store. I went there to pay for service but Sun Tek said it doesn't service Intex filters and pumps because the parts are too hard to come by. Still the manager and assistant there that day agreed to take a look for no charge and were able to get the valve open. It was, indeed, stuck because sand had gotten in it. They flushed it for me. It was a project re-installing all the other parts of the sand filter but now I'm up and running. Now, I just have to get all the sand out of the bottom of the pool -)
 
  • Like
Reactions: Texas Splash