Hayward S200 filter replacing multi-port valve: PVC adapter threads too long?

krick

Member
Jun 11, 2013
8
Cary, NC
I have an older Hayward S200 sand filter and I'm replacing the multi-port valve because it is cracked internally which allows water to leak past the "spider" gasket out the waste line.

Additionally, it has always leaked where the PVC threaded adapters screw into the valve body and I was curious why.

After cutting some of the PVC piping and unscrewing the adapters. It appears that the threaded portion of the adapters are nearly 1/2 inch longer than they need to be. Whoever assembled it originally put about 10 layers of Teflon tape on the threads (not an exaggeration) and then added a thick bead of clear silicone around the joint between the valve and the PVC adapter to fill the gap. And it STILL leaked. The valve definitely wasn't cracked from over-tightening. It appears that water was just leaking past the threads.

I'm suspecting that the reason this didn't seal was because it didn't get far enough up the taper to make a good seal (assuming PVC threads are even tapered). But I could be completely wrong.

Do they make PVC adapters with different thread depths and/or tapers? I've looked at a ton of pictures online and it looks like they do, but it might be an optical illusion from the way they are photographed.

Before I spend a bunch of time re-piping this back together with the new valve, I want to make sure I use the correct adapters so this doesn't leak again.

Any ideas?
 

sktn77a

Gold Supporter
May 16, 2010
2,198
Chapel Hill, NC
I have a Hayward S240T filter and don't have any leaks with the Lasco 1.5" fittings (but I use RectorSeal Tplus2 joint sealer). I guess it depends on the fittings you have - Spears, Lasco, Charlotte, etc. You might just have to try a couple and see which fit best.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.