Filter pressure oddity

Texasnative

Well-known member
Nov 28, 2020
46
Texas
Still can’t figure out why the signature isn’t showing up. It’s there in my profile. Here is the info: 50k in ground free form w/ spa & negative edge. Jandy 1.5 hps, Jandy 2.0 hp, and Jandy variable speed filter pump. 60Sq in DE filter w/ ozone, Jandy heater, polaris w/ booster pump.
I have a service maintaining the pool so I’m not generally testing it as they handle this. I’ll have to find out test kit and see what kind it is but it is some sort of pentair kit.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
44,429
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I have a service maintaining the pool so I’m not generally testing it as they handle this. I’ll have to find out test kit and see what kind it is but it is some sort of pentair kit.
We can not help if you do not test your water chemistry with a proper test kit. See Test Kits Compared
 
  • Like
Reactions: proavia

reggiehammond

Gold Supporter
Oct 4, 2020
375
Fort Worth, Texas
Pool Size
30000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Thx. Oddly enough I just checked everything and now the pressure and water flow is back to normal at 20 PSI this morning. The testing aside what could cause the fluctuations in pressure like that?
PSI is useful for assessing filter cleanliness; you mention backwashing, but never a full clean. Are you adding DE every time you backwash? If not, you are reducing filter effectiveness and your PSI readings are no longer reliable.

Your initial post was exactly the same symptoms I had when I my filter plugged after a drain and refill. Flow was weak, pump pot was not 100% full, etc. I'd encourage you to get serious about the filter and your system, break it all the way down, clean thoroughly, then add appropriate amount of DE.

Then you can work on your VS speeds; I run mine at 1100 rpm, with drain off. It skims great and I've also got a large pool. There's a lot to learn, but you'll find that pools are MUCH simpler than pool stores and pool companies want you to believe.
 
  • Like
Reactions: mknauss

Texasnative

Well-known member
Nov 28, 2020
46
Texas
PSI is useful for assessing filter cleanliness; you mention backwashing, but never a full clean. Are you adding DE every time you backwash? If not, you are reducing filter effectiveness and your PSI readings are no longer reliable.

Your initial post was exactly the same symptoms I had when I my filter plugged after a drain and refill. Flow was weak, pump pot was not 100% full, etc. I'd encourage you to get serious about the filter and your system, break it all the way down, clean thoroughly, then add appropriate amount of DE.

Then you can work on your VS speeds; I run mine at 1100 rpm, with drain off. It skims great and I've also got a large pool. There's a lot to learn, but you'll find that pools are MUCH simpler than pool stores and pool companies want you to believe.
I must not have said it but yes I did break it down, clean and inspect the filter. Yes on the DE after the backwash.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread