Blue Diamond Question/Issue

jordanlanderson

Well-known member
Dec 28, 2014
82
Edmond, OK
#1
Good Evening!

So...I purchased a home that came with a pool and a Blue Diamond Robotic pool cleaner (Model AG11XXXX). Today for the first time I dropped it in the pool to get it nice and clean. I put it in the pool and switched it on - it really didnt do anything. I tried turning it on 3-4 times and even pulled it out removed the basket and then tried it again and nothing. It is an older unit and there is no owners manual so I went on Watertech's website and downloaded the manual. The warning on the front page about putting it in the pool before turning it on made me realize I am not completely certain it was fully submerged prior to me turning it on. I put in on a step/stool in the deep end and it may have been partially above the water line - I do not recall. So all of that being said...am I totally screwed? Is the thing ruined? Anything I can do to troubleshoot it?

Any help or advice is appreciated!
 

duraleigh

Admin
Mod Squad
TFP Expert
Platinum Supporter
LifeTime Supporter
In The Industry
Apr 1, 2007
31,273
Sebring, Florida
#2
I doubt the lack of complete submersion was the culprit......although you did it without submersing 4-5 times? Probably was not working for some reason before you tried it out.

PS - We ask for your location to help us in determining your climate for pool water management....."Here,There" won't help us or you.
 

JasonLion

TFP Expert
Platinum Supporter
LifeTime Supporter
May 7, 2007
37,879
Silver Spring, MD
#3
Welcome to TFP!

There is an interlock, so that once the unit turns off, it won't turn on again until it has been off for a couple of minutes. It seems possible that it turned off right away because it was not completely submerged, and then you didn't leave it off long enough after that for it to reset. Of course it could also be broken, or perhaps it didn't actually have power (GFI tripped, etc.)
 

jordanlanderson

Well-known member
Dec 28, 2014
82
Edmond, OK
#4
Alright back after a week of holiday fun. Thank you for the suggestions - I tried it again today to no avail. Thinking I will need to call it in or take it to a store for repairs. One dumb question - does the power supply need to charge - or can you just plug it in an go?

Thank you!

Ps...I updated my location.
 

jordanlanderson

Well-known member
Dec 28, 2014
82
Edmond, OK
#6
Good Morning All-

I figured I would post a quick update and an additional question. I have now opened the pool for the summer and it is quite dirty (expectedly so) but, my frustration is with this Blue Diamond unit. I can get it turn on and work but it does not work for very long. At the most it has worked for 20 minutes. Now I realize that when the bag is full it probably shuts off but this is not always the case. It seems to just work sporadically but never for very long.

The unit appears to be fairly old so I may just need to replace but, I was hoping to milk it along this year as we have a lot of expenses with the new house.

ps...my other thought is to just get a Kreepy Krawler Kruiser off craigslist for $100 as I had success with those at another house I had.

Anyways - thanks for any help or advice you can provide!