Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Polaris Truck Cleaner

  1. Back To Top    #1

    Join Date
    Jul 2007
    Location
    Katy, TX
    Posts
    188

    Polaris Truck Cleaner

    Our pool is about 15m old. We have this cleaner set to go 2 hrs a day. No problems with it until about 2 - 3 months ago. It started to get caught up in the hose. This happened every once in awhile and then gradually became worse and wrose so that now it happens 5 days a week. Once it get caught, that is sit. It won't go. Here's pics of what happens:



    We had the pump (intelliflo 4 spd pump)running at about 2700. We thought maybe we needed to up the pump? But it is strange that the pump has been going the same with out a problem until now. Thanks guys. This is aggravating b/c it is not doing it's job.
    ~Andrea

    24,000 IG with spa and 4 ton waterfall. Equipment: Pentair 520 Clean & Clear, Pentair VS+SVRS Intelliflo, Pentair Whisperflo 2 HP, Polairis Cleaner, Intellibrites, Pentair Rainbow 320 in-line Chlorinator, Pentair Easy touch 8 wireless and spa side remote.

  2. Back To Top    #2
    hodapmj's Avatar
    Join Date
    Oct 2007
    Location
    Arkansas
    Posts
    53
    From the photo, your front wheel drive treads appear to be worn away from the pebble tec. It may be as simple your Polaris is just spinning its wheels and getting no traction. They are easy to "rotate" your treads. Move the rear treads to the the front tires.

    While you are switching the treads, turn each front wheel separately. Is the gear driven motor spinning freely when you turn each wheel manually or is the drive gear slipping? If it slips you will have to remove the cover and adjust your drive gear for the slipping wheel. This is very simple by removing a couple of screws from the bottom of the unit and pulling off the top of the Polaris.
    24K gal. 22 X 40' Fox Lagoon IG Vinyl, 7' Fox 25 jet raised Spa, Intelliflow VS-3050 pump, Intellichlor IC-40 SWG, Pentair Easy Touch Controller, Easy Touch Wireless Remote, Pentair Legend cleaner w/ booster pump, Pentair 250,000 BTU heater, Pentair Tagelus Sand Filter, & Pentair Intellibrite LED lighting.

  3. Back To Top    #3

    Join Date
    Apr 2008
    Location
    Central Texas
    Posts
    326
    It looks to me like you have leaky floats on your feed hose. They can crack and allow water inside, which defeats their purpose. They are supposed to hold the hose up and out of the way of the Polaris as it roams the pool. Also make sure that you have the floats positioned properly on the feed hose. The locations are listed in the owners manual.
    26,000 Gallon Gunnite IGP
    2 HP Challenger High Head Pump
    60sf Nautilus DE filter
    Polaris 280

  4. Back To Top    #4

    Join Date
    Jul 2007
    Location
    Katy, TX
    Posts
    188
    Thanks for the suggestions!!! I will do as you all say and check it all out. I also discovered yesterday, as I was trying to get this all figured out, that when the cleaner comes on, the hose connector to the pool slips out some so that it is not getting full pressure. If that makes sence. I tooled around with it and it sorta just pops out when the cleaner comes on. The grooves on the hose connector appear worn. Not sure if that is a replaceable part or if I will have to buy a whole new unit. I'm a little ticked that would become "worn" so quickly and thought that would be something that would have lasted a couple years. Anyway, thanks for the input and I will check those things out!
    ~Andrea

    24,000 IG with spa and 4 ton waterfall. Equipment: Pentair 520 Clean & Clear, Pentair VS+SVRS Intelliflo, Pentair Whisperflo 2 HP, Polairis Cleaner, Intellibrites, Pentair Rainbow 320 in-line Chlorinator, Pentair Easy touch 8 wireless and spa side remote.

  5. Back To Top    #5

    Join Date
    Apr 2008
    Location
    Central Texas
    Posts
    326
    Andrea, most likely one of the pins is broken on the part in the wall that the Polaris attaches to. They're pretty small and easily damaged. The good news is that it's easy to replace, and not too expensive. $4-5 as I recall.

    You can just unscrew it from the wall to inspect (or just go in the pool with a mask or goggles and look inside).
    26,000 Gallon Gunnite IGP
    2 HP Challenger High Head Pump
    60sf Nautilus DE filter
    Polaris 280

  6. Back To Top    #6

    Join Date
    Jul 2007
    Location
    Katy, TX
    Posts
    188
    Thanks! I am about to go swimming so I will check that out too. You all have been a wealth of info. and I appreciate it! ANd you show you what a dummy I am, I have been searching high and low on internet for my cleaner and actually it is a pentair not polaris - duh! So sorry for inconviencing anyone with my lack of knowledge!
    ~Andrea

    24,000 IG with spa and 4 ton waterfall. Equipment: Pentair 520 Clean & Clear, Pentair VS+SVRS Intelliflo, Pentair Whisperflo 2 HP, Polairis Cleaner, Intellibrites, Pentair Rainbow 320 in-line Chlorinator, Pentair Easy touch 8 wireless and spa side remote.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •