Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: new filter leaking??

  1. Back To Top    #1
    midtngal's Avatar
    Join Date
    Oct 2007
    Location
    Nashville, TN
    Posts
    478

    new filter leaking??

    I now have my equipment hooked up and running! But, it looks like the sand filter is drippping...or is it supposed to do this??





    In the first picture I was lucky enough to catch a drop coming out of the valve. Just an overview of the equipment in the second for reference. This would seem to be such a waste of money here. The pool itself doesn't seem to be losing any water. I haven't mentioned it to my PB yet - want to know the answer before I ask him so I'll know if he's lying to me yet again.

    Thanks bunches!
    Karen
    10,700 gal IG vinyl
    Pentair Triton II TR50 sand filter
    Pentair Booster Pump
    Letro Platinum pressure side cleaner
    Emerson 1HP pump
    Bioguard Mineral Springs SWG
    2 skimmers

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887
    No it should not drip like that. The fix is probably very simple. Make sure your builder takes care of it.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3
    midtngal's Avatar
    Join Date
    Oct 2007
    Location
    Nashville, TN
    Posts
    478
    Thanks Jason! Glad to know it's an easy fix. 8)
    10,700 gal IG vinyl
    Pentair Triton II TR50 sand filter
    Pentair Booster Pump
    Letro Platinum pressure side cleaner
    Emerson 1HP pump
    Bioguard Mineral Springs SWG
    2 skimmers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •