Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Pentair Pool Filter Housing Seems To Be Holding Water

  1. Back To Top    #1

    Join Date
    Feb 2018
    Location
    Boynton Beach Florida
    Posts
    2

    Pentair Pool Filter Housing Seems To Be Holding Water

    Hi - My name is Michele. This is my first time on the site (or any pool forum site for that matter). I'm a single mom and have been taking care of my own pool for 15 years or so... I did pools with my ex years ago and learned quite a bit, Thank God.. Some problems I can totally fix, others not. My pool is about 14,000 gallons. 8 feet to 3 feet - Steep slant and shaped like a penguin - fiberglass - built in 1980 or 1984 (I forget and the real name of the shape - in my file - will add later if need be). Anyway - the pool filter housing just seems to sound odd - a lot of water when I open it and the filter is not being saturated with the algae (green) even after adding two jugs of chlorine. Can this simply be that I need a new cartridge or do I have a different problem. It's running like a charm - excellent circulation - no main drain in this pool - they tried to install twice and for whatever reason, never got it connected. Can see where they attempted to install it initially. Suggestions, answer or any input would be greatly appreciated...

    Hope everyone is having a swell day

    Michele

  2. Back To Top    #2
    Mod Squad woodyp's Avatar
    Join Date
    Apr 2010
    Location
    East Texas
    Posts
    10,188

    Re: Pentair Pool Filter Housing Seems To Be Holding Water

    Welcome to the forum.. Any idea of what your "clean" filter pressure is (either after backwashing or cleaning the cartridge(s))? Dead algae will clog up that filter and raise the pressure which lowers your circulation.
    We'd like to have a full set of test results and how how you obtained them as well.
    16x32x52" Steel Cornelius Miramar AGP Vinyl liner 13,100 gal. Buried 2 ft.
    2 Speed Hayward Power-Flo Matrix 85 g.p.m. 22" 250lb. sand filter hard plumbed
    Pool Rover Jr., Pool Blaster Max, Diver Dave TF100 Test Kit/Speed Stir
    Margaritaville Frozen Concoction Maker, Liqour Chiller, & Drink Mixer & Party Tub----Collect 'um all!

  3. Back To Top    #3
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    9,833

    Re: Pentair Pool Filter Housing Seems To Be Holding Water

    M,

    Welcome to TFP... a great place to find the answers to all your pool filter questions... no matter what your 'Beach' is called...

    Since most 'filters' make no noise, I want to make sure that we are both on the same page... The "pool pump" sucks the water from the pool and then pushes it through the 'Filter"...

    When you say.. "a lot of water when I open it.." I am puzzled, because in most filters there is a drain plug that you take out before opening them.. I just want to eliminate the possibility that you are opening the lid to the pump and not opening the actual filter...

    If your pump is working and you have green pool water, I would think that your filter cartridge would be coated with green 'goo'... This would cut way down on your circulation, but you say your circulation is excellent... this also confuses me...

    How about posting a picture or two of your equipment pad.. this would help us understand your problem better and allow us to help find the answers to your problem.

    Thanks,

    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Caldera Spa.

  4. Back To Top    #4

    Join Date
    Feb 2018
    Location
    Boynton Beach Florida
    Posts
    2

    Re: Pentair Pool Filter Housing Seems To Be Holding Water

    I am positive I am opening the filter and not the trap, thank you though... Woodyp - thank you for mentioning the possibility of dried algae/material. I didn't realize my son had left the filter out of the housing overnight, so this may be the case. I do need a new filter cartridge regardless, so I am hoping I can resolve the problem by blasting the line with the hose and installing a new cartridge. I thank both of you very much for your help. (Also, I may have misspoke on the depth - 10ft to 3ft. - oddly deep in the deep end

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •