Trouble with Sundance spa- FLO error and heating issues

RDspaguy

In The Industry
Mar 21, 2020
587
Cabool, Mo
Still the same issue. By putting it in economy you are changing when it allows it to heat. No call for heat, no flo error. As soon as you turn on the pump it initiates a call for heat. Either your flow switch is not closing, is not functioning, has a loose or corroded connection, or the circuit board is bad. Most likely it's just a bad switch, but check for a connection issue first, since that is free.
 
  • Like
Reactions: Deibi1016

Deibi1016

Active member
Apr 24, 2020
28
New Orleans LA
Hello good friends, my question is why the jets do not turn off, and I see some hoses that are in the air. O would like to know if these hoses have to be like that and why my jets are like that now. This is the first time that the jets are like that. And if some one can tell me how many gallon these jacuzzi has, it is a sundance spas model 750/850.

Thanks20200504_165116.jpg
 

Attachments

Deibi1016

Active member
Apr 24, 2020
28
New Orleans LA
The therapy jets, I do not know what speed, because I turned on the jacuzzi and the jets start. No error, just the FLO error, anand it's at weather temperature, because my heater doesn't want to work. What about the houses?
 

RDspaguy

In The Industry
Mar 21, 2020
587
Cabool, Mo
The therapy jets, I do not know what speed, because I turned on the jacuzzi and the jets start.
Jets will run on low speed for filtration and heating. If it is not heating it will continue to run as long as the system calls for heat in standard mode. In economy mode it only allows heating during programmed filter cycles.
 

Deibi1016

Active member
Apr 24, 2020
28
New Orleans LA
Solid flow means the flow switch is reading closed when it should be open. Did you replace the tee fitting, or just screw in the flow switch?
8 replace the tee. I bought a new flow switch. Also check is that this jacuzzi has an ozone, but it broke and the flow switch that I bought does not bring the part to connect the ozone and through that hose it is liquidating a little. How I can fix tha error.

Thank you
 

Deibi1016

Active member
Apr 24, 2020
28
New Orleans LA
This?Jacuzzi® Spa Ozone Mazzei Injector
Get this.
Or just remove the mazzei valve and connect the pipes with some barb couplers, a piece of 3/4" hose and some hose clamps, all available at most hardware stores.
I did exactly what you said when I got the new flow switch. I remove the mazzei and conect the flow switch directly with the hoses.

How I can fix the flow error? this is frustrating, fix something and it comes out again.

Thank you.
 

RDspaguy

In The Industry
Mar 21, 2020
587
Cabool, Mo
That's the million dollar question right there. A new flow switch should not be giving you a solid flo error, and it can't be the board because it is a different error than before.
When you first turn on the breaker does the circulation pump come on immediately or is there a delay, or does it not turn on at all?