Sta rite heater error code

ps0303

TFP Expert
In The Industry
Jul 6, 2011
4,128
FL
Moved from here.
Hello, I know this is an old thread but I am having the same problem. E06 error with service heater light on. SFS light on pc board. Replaces sensor, still not working . Checked thermal regulator, looked good. What next?
Check all of the wiring to the board to make sure nothing like a rodent has chewed it. If that looks good, then possible bad board.
 

JamesW

TFP Expert
Mar 2, 2011
28,291
To check the stack flue temperature, press and hold the "Pool On" button for about 5 to 10 seconds.

E06 is a bad board, shorted stack flue sensor or a board not set for the correct sfs (limit type switch vs. temperature sensor).

What is the heater history? Age, recent repairs etc?

Check to see if you have a stack flue sensor or switch.

A switch is only open or closed.

A sensor checks actual stack temperature by measuring the resistance of the sensor and correlating it to temperature based on a known graph.

E06 means that the board is getting a reading of 0 ohms from the sensor.

Check the resistance, if it's 0, you have a bad sensor.

If it's high, you probably have a bad board.

The sensor should be reading 3.8 Mega Ohms at 77 degrees Fahrenheit.

Check to make sure that the board is set for the correct sensor type.
 
  • Like
Reactions: setsailsoon
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread