running low speed - air in pump basket

drband

LifeTime Supporter
Jun 12, 2007
24
Hi: Converted my Superpump 1hp to a 1hp 2 speed this spring... works great! My question is... why am I getting a bit of an air bubble in my pump basket when I run it on low speed? The air bubble seems to grow a little bit if I run it continuously for a day or so. Water seems to be moving fine, no air coming out of returns, and there is never any air in the pump basket when I run it on full speed. Just trying to figure out if there is some kind of problem here or not. Thanks.
 

Bama Rambler

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2009
23,062
SouthWest Alabama
It could be that you have a small air leak (lube the pump basket o-ring) and on low it doesn't expell the air but on high it does. Also on low you won't have as much negative head so it could possibly leak more on low than on high.
 

Bama Rambler

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2009
23,062
SouthWest Alabama
That was just a memory jogger in case you hadn't remembered to do it. It could be a leak in the plumbing or where the basket connects to the pump, etc.
 

JasonLion

TFP Expert
Platinum Supporter
LifeTime Supporter
May 7, 2007
37,880
Silver Spring, MD
Having a relatively small air bubble, compared the the size of the entire strainer basket, isn't a problem as long as the pump doesn't lose prime because of it. It might be normal, or it might be a sign that there is an air leak that might get worse.
 

Other Threads of Interest