Pentair Power Supply

Philo

Well-known member
Oct 8, 2015
922
San Diego, Ca.
Woke up to no lights on the cell......

The breaker at the panel was fine so I replaced the flow switch (I previously bought an extra because of all the failures posted on TFP). Still no lights.

I wanted to check the fuse on the bottom of the power supply but the cheap plastic cap would not let it pop out. I took off the outside cover to see what was going on. This is a very flimsy design but I manage to finesse it out and saw the fuse was blown for some reason? Even getting the fuse out of the holder without braking it required a delicate finessing technique. I went to the store to get a new 10a 260v replacement. Anyway, I put the new fuse in and tried to replace holder. No luck. This fuse holder looks like it was designed to be used only once.......

Back to the store to buy a standard in line fuse holder. Next, I had to cut the old fuse holder out (not too simple because the cable receiver that runs the cell's wires to the power supply is right in the way). Removed that. Finally, I had to solder the new in line fuse holder in, replace the cable receiver and outside cover.

Success! the lights of the cell came on.

My rant is, that replacing a fuse should be MUCH simpler.
 

tucsontico

LifeTime Supporter
Mar 30, 2014
275
Tucson, AZ