Pentair Easy Touch help

AmandaP78

New member
Jul 27, 2010
2
My Easy Touch wireless says "NO COMM" - the control board works just fine and the wireless unit comes on but won't connect. I replaced the batteries...
The pool is almost 4 years old and the antena has been in the same place the entire time.
How would I even attemp to find out what is wrong? I don't want some pool company to come out and tell me I need to replace the entire thing just to get a sale!
 

Pool Clown

In The Industry
Sep 5, 2008
1,882
Silicon Valley, CA
It sounds like your controller lost the wireless address.

Try this:
At the outdoor control
1.press menu
2.press down button, scroll to settings.
3.Press right button to select.
4.Press up button, scroll to "Wireless Address"
5.Press right button to select.
"Address Wireless scanning" will display, Then "Sending Address" will display.
6.Now repeat steps 1-5 with the handheld wireless controller, "Address Found" will display
7.Press menu button on control panel 3 times to return to main screen.
 

lbridges

LifeTime Supporter
Nov 12, 2009
323
Indialantic, FL
Mine did the same after a recent power outage. Perhaps strangely everything seemed to be running fine, VS pump going up and down in speed via programmed start/stop times, etc.

Pool Clown stated the method to make the panel and wireless unit sync back up. And Serge's advice is spot on as well. What may need to be noted is that you may need to go to the house service panel and cut ALL power to the Easytouch panel. My story is I have a circuit breaker on the Easytouch load center that cuts off electricity to the automation part (the panel LCD goes dark, etc.), but for some unknown reason turning that breaker off, then on, and resetting the Easytouch through the panel's Reset button did nothing. Cutting power at the house main panel to the Easytouch then following the above procedure did work.

Maybe I should also throw in that the previous power outage made the VS pump stop responding to the mode being Service or Timeout, but everything (including wireless) worked in the auto mode. I think the Easytouch needs some work in recovery from a power glitch. I have whole house surge protection too BTW in case anyone has ideas to try for remedies.
 

UserTx

New member
Jul 30, 2011
1
Thanks Pool Clown and lbridges. You have to turn off the pool from your house main circuit breaker and then turn it on per lbridges' instruction. Then follow the instructions from Pool Clown's and you should be able to reestablish the remote control. Worked like a charm.
 

Solana_Beach_Gal

New member
May 4, 2014
1
Solana Beach, CA
Thank you Pool Clown, Ibridges and UserTx! All was fine after I used the main circuit breaker on the the house to turn off the pool controls than following Ibridges' instructions. Saved me a lot of headaches! Thank you!
 

tdub4

New member
Sep 13, 2007
1
I know some of these posts are old, however I was able to use this to get my remote communicating with my main board again. I tried re-addressing the main board and then the remote first and it did not work. I followed the suggestion from above and cut power to the main board for 1 minute (we have a switch right next to the main system on the outside wall did not use the breaker or the whole-house cut-off). I went through the re-addressing procedure again and *BOOM* back in business. Thanks to all for their help!
 

Mycall9550

Well-known member
Apr 5, 2017
187
Houston
After idle use for over 2 weeks I had this same problem. The instructions provided by pool clown worked (for me without shutting down the main panel).

- - - Updated - - -

How do you readdress if you dont have a menu interface outside? I have a remote only. Thanks
There should be a panel outside, the remote is just that for the panel that has the automation components.
 

Other Threads of Interest