New pump making strange noise

budysr

LifeTime Supporter
Aug 26, 2007
129
Pensacola
My pool is only a couple months old and the pump has off and on made some abnormal noises. This is a 1hp Sta-Rite pushing through a sand filter in a 14000 gal. Pool. When we first started up, I noticed a loud vibrating noise around the shroud(right behind the clear-lid skimmer) that I was able to stop by turning the pump off, then back on again. It did this maybe 2 or 3 times the first week. I was thinking air being primed out. Now just in the last couple days, the noise has come back and I couldn't get it to go away at all. I disassembled the shroud and checked to make sure the impeller was clean and I reassembled the shroud and skimmer to the motor making sure all the bolts were tight(they were actually not very tight before I did this). There is also a plastic piece(a wear ring) that sits between the shroud and the actual impeller so I was thinking that maybe this dude was what was rattleing and making the awful noise. Now today the pump is running quiet again(so far) except that I hear a click or shift sound around the shroud area about every 30 sec.s or so. Its almost like a clutch keeps engaging or the pump is trying to "catch up" with itself(does that make any sense :? ) This thing is pumping the water fine and I don't see any air bubbles. Any ideas on what is going on with this thing? It is under warranty and can be replaced but not till next week. I thought bearing going bad but wouldn't that mean that it would be loud all the time and not intermittently?
 

budysr

LifeTime Supporter
Aug 26, 2007
129
Pensacola
I went back out and listened to it some more and its more like a change in the sound of the flow and only lasts a few seconds. The pressure guage remains steady though. I still don't think this is normal since I never heard these sounds before even when it was LOUD.
 

sammm

LifeTime Supporter
May 10, 2007
257
North Richland Hills, TX
budysr said:
There is also a plastic piece(a wear ring) that sits between the shroud and the actual impeller so I was thinking that maybe this dude was what was rattleing and making the awful noise.
That's probably the pump seal. It's actually made of ceramic (I think). It shouldn't be worn out already, but I guess it's possible. Cheap enough to replace and see if it makes any difference.
 

budysr

LifeTime Supporter
Aug 26, 2007
129
Pensacola
This piece is called a wear ring. Its not a pump seal. I think its function is to keep the impeller from rubbing against the shroud. Anyway, I guess nobody has any ideas on whats going on with this pump?
 

robdavisjr

LifeTime Supporter
May 25, 2010
3
Bear, DE
Budysr,
(5 years later) Did you ever figure out what the problem was? I am currently having a similar issue. My 2HP Waterway pump started making an intermittent rattling noise (yet, still steadily pumping water). I pulled the basket out and reached down into the shroud and felt (what I believe is) the "wear ring," which seems loose and leads me to believe that the wear ring is the culprit.

To all,
1) Has anyone else had a similar issue? My dad suggested replacing the whole pump for $300-400 (which after reading a few TFT posts, does not sound like the best solution). The pool is only 5 years old.
2) How long should it take to replace the wear ring?
3) Could the impeller be damaged as well?
4) Where is the best place to buy parts?

Any help would be greatly appreciated.

Thanks,
Rob