mobiletouch2 connectivity issue

poolerik

Member
Jun 12, 2017
7
San Jose, CA
My mobiletouch2 suddenly dropped connection. I've tried the reconnect sequence as described in the Pentair literature, but when I press "LOCK ON ADDRESS" nothing happens. I've tried power cycling the intellicenter a few times, along with disconnecting spa remote & antenna board, before and after power cycle - nothing seems to make any difference. I saw reference to setting an address manually, but that doesn't seem to be an option with v2.040 on the mobiletouch.

On the antenna board, I've noticed that the POWER LED is solid, the 485 LINK LED blinks occasionally, but the RF LINK LED never blinks... I tried to figure out if either the mobiletouch2 or the antenna board was not transmitting. I don't have any way to tell for sure, but when holding a radio next to the mobiletouch, there is a sound change when it comes on, when I try the same at the antenna board there is no change. It makes me think the antenna board is not transmitting anything...

Is there a way to troubleshoot the antenna board or this whole connectivity issue?

Please help!
-Erik
 

ogdento

Bronze Supporter
Mar 30, 2015
578
Chico, CA
Hey Erik,
The 485 light blinks when the antenna receives a packet from the outdoor board - so it blinking is a good sign. The link led blinks when it receives a command from the handheld - but it won't blink if the handheld isn't linked to the outdoor board.

On the antenna card... is there a chip labeled "Linx" or a chip labeled "Laird"? (or, is the fcc:id on the back of your handheld P4HMOBILETOUCH2 or P4HMOBILETOUCH2A? The '2A version is the newest.

First thing to do is inspect/test your cabling. Use a multimeter in conductivity mode. If that checks out ok, you need to determine which device is bad - and it could be the handheld, the antenna, the spa controller, the outdoor board. Use the process of elimination... power down, disconnect everything from the comm port, and then plug each device in one in at a time to see if it can talk to the outdoor board. If you have a vs pump it will show "display not active" on it's lcd. If not, does only the spa remote work? (if either the vs pump or the spa work, then the outdoor board is ok). Now connect only the antenna card and try to set up the wireless address again.
 

Dirk

Gold Supporter
TFP Guide
Nov 12, 2017
7,119
Central California
Erik, I don't know what a mobiletouch2 is, or on what frequency it operates, but see if there's anything in this recent thread that you can use:

 

poolerik

Member
Jun 12, 2017
7
San Jose, CA
Continuity checked-out OK on all the wires. I power cycled with just the antenna card and it couldn't connect - tried the other set of pins without success, then added the vs pump (display not active shows up), tried again, and the spa remote, and it wouldn't connect.
 

ogdento

Bronze Supporter
Mar 30, 2015
578
Chico, CA
Ok, what you've got so far is:
- the wiring is ok
- the pump is showing display not active
- the spa is working/communicating with the outdoor board

Assuming the setup sequence is correct, it certainly seems like the card is bad... the 2.160+ fw versions have that manual code setup where it flashes the code using the aux leds on the outdoor panel and then you can enter the code you see - but you're correct that the 2.040 version doesn't have that. I don't have another explanation for why it wouldn't work... their "walk 20-30" feet away shouldn't affect the ability to link - but if you don't do that step you might find your range is limited due to interference from some other device(s).

I've not been able to verify transceiver operation by sniffing the rf output... it's impractical without expensive equipment (e.g. spectrum analyzer) - these cards use a frequency hopping scheme and my software radio lacks the bandwidth to show me a complete picture. So I test the cards with an Easytouch wireless remote and an Easytouch outdoor board (the EasyTouch setup is simpler than the IntelliTouch). If you've got a friend with a pentair wireless remote (mobi or et), that's an option.