Jandy CL-580 clamp leak

Mindflux

LifeTime Supporter
May 7, 2014
193
Pflugerville, TX
I'm late on the filter cleaning, but my pool guy took apart my CL580 and rinsed the filters, took the o-ring off and wiped it down and wiped down the channels on the top and bottom of the shell and liberally lubed the o-ring and put the top half back on and put the band on again. We tried several band positions (30 degrees or so off from where I'd normally have the band tightened) and it always leaks where the back hinges and the front tightens. We've used a mallet to get the band tighter and then tighten it more, to where the band is almost touching itself.

No matter how much lube, tightening, adjusting etc we cannot get the filter to stop leaking at those two spots. We don't think it's the o-ring because adjusting the clamp left or right a bit always leaks at the same spots relative to the clamp.


Any ideas?
 

crabboy

LifeTime Supporter
Jul 24, 2007
628
Suwanee, GA
I've lost all the coating on my 460 band and it still clamps down tight.

I'd suspect two things. Either you are not clamping it down tight enough or you need a new gasket. I had a leak once after I put it together and I had inverted the rubber gasket (inside was on the outside) and it caused it to leak. Took it apart, flipped the gasket and the leak was gone.

Make sure the bolt is peaking out of the long nut about 1/4 to a 1/2 inch, at least that is the gauge I use on mine.
 

crabboy

LifeTime Supporter
Jul 24, 2007
628
Suwanee, GA
It's kinda like turning the inside of a rubber band to the outside. I think the gasket is the same either way, but mine like being the way it was for years before it got flipped.
 

Lilypad

Bronze Supporter
Nov 12, 2016
196
Plano, Texas
I just took my filter apart and cleaned it yesterday. It's a 340, but the O ring is shaped the same as the 460. The cross section of the ring shows it is oval. Make sure the long diameter section of the oval is vertical.
 
Last edited:

Mindflux

LifeTime Supporter
May 7, 2014
193
Pflugerville, TX
Yep. No matter what we did we couldn't get a good seal so I bought a new o-ring. When we put the top half of the shell back on it was evident the other one had lost it's shape or became compressed because the shell had a lot of 'gap' between the top and bottom until it was clamped back down. Leak free on the first try with a new o-ring.
 
  • Like
Reactions: Lilypad