Help with Pentair Easy Touch remote - cannot connect

AmyInTX

New member
Mar 1, 2017
2
Houston
Hi. I am new to the forum, but I found this troubleshooting an issue we are having with our pool remote.

It says it cannot connect. We have done everything we can think of to reset it and have replaced the batteries. The guy who helps service our pool *thinks* the issue is with the card attached to the antenna on the control panel (I think I'm putting that correctly).

Anyone have any ideas? Is this something we can fix ourselves? The guy who helps us just says order a new system, but that doesn't seem right.

Thanks in advance!!
 

AmyInTX

New member
Mar 1, 2017
2
Houston
To clarify, it is saying "NO COMM".

I found a few things to try online. I have gone to the master panel to send the address and tried receiving the address via the remote. I also shut down power to the pool equipment entirely and then did the address send again. No luck.

Thanks.
 

Patrick_B

TFP Expert
LifeTime Supporter
Jun 7, 2011
14,999
Midland TX
Hey Amy, welcome to the forum!

It's been a while since this happened to me right after ours was set up, but I remember for sure that resending the address from the main took care of it. Sorry I'm no more help, but I remember how frustrating that was, and my PB was out of town of course. Pentair told me that, and it worked.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
11,418
Bedford, TX
Amy,

Sorry, but I have SceenLogic, so I'll be of no help with this issue, but I know someone that might.. I'll let him know he's wanted..

Thanks for posting,

Jim R.
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
14,874
Tucson, AZ
Check the antenna that connects to the main panel. Make sure all the connections are solid. The antennae (both for ScreenLogic and the RF remote....looking at you Jim!!) are susceptible to getting fried by power surges and what not. You might need to replace it.

You may need to put a call into Pentair for more advanced troubleshooting as they can walk you through the detailed diagnostic menu.


Sent from my iPhone using Tapatalk
 

Other Threads of Interest