Filter pressure dropped

jlhaz

LifeTime Supporter
Aug 18, 2007
99
0
#1
Hello,

I turned on my pump this morning to add some stabalizer. I added it to the skimmer basket and checked the pressure guage. It was at 20 PSI, the normal pressure for the filter.

I heard some bubbling sounds coming from the pool, and I went out to check. There was little or no pressure coming from the returns, and the pressure guage dropped to 0. The pump is still running however.

Did I do something wrong? did I really mess things up? :(

Thanks!
 

JohnT

Admin
Mod Squad
TFP Expert
Apr 4, 2007
9,446
0
SW Indiana
#2
You may have added it too quickly and formed a clog in the skimmer pipe. It will dissolve e-v-e-n-t-u-a-l-l-y, but to hurry it, you can use a hose to flow water back the other way from the pump basket to try to clear it.
 

JasonLion

LifeTime Supporter
Platinum Supporter
TFP Expert
May 7, 2007
37,879
5
Silver Spring, MD
#3
When you add stabilizer to the skimmer too quickly it can sometimes temporarily clog the pump strainer basket. If you can keep some water flowing the clog will pass through to the filter and everything will be fine. But if it completely clogs the pump strainer then you need to turn things off and clean out the pump strainer basket.
 

jlhaz

LifeTime Supporter
Aug 18, 2007
99
0
#4
Thanks!!!

I'll go check those 2 things out.

This is my first time using BBB and doing the chemicals myself so i'm still learning :)
 

jlhaz

LifeTime Supporter
Aug 18, 2007
99
0
#5
The pressure came back, it's a little lower than normal but it looks like the clog ls clearing just like you all said.

THANKS AGAIN! :)