Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Spa Jet Blower problem

  1. Back To Top    #1

    Join Date
    Nov 2007
    Location
    Rockland County, NY
    Posts
    65

    Spa Jet Blower problem

    Hi All,

    We have a 20 X 40 IG with attatched spa. The spa has eight jets. When I run the blower 2 or 3 of the jets deliver very little air. I am assuming (probably incorrectly), that the water column in those lines is preventing the air from being pushed through. The blower is 2 hp. What is the remedy? Can I safely attach my air compressor to clear out the lines? Any help would be greatly appreciated. Thanks.

    Rob
    27ft Above Ground Pool
    Sand filter

  2. Back To Top    #2

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Spa Jet Blower problem

    Can you post a pic of the jets?

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  3. Back To Top    #3

    Join Date
    Nov 2007
    Location
    Rockland County, NY
    Posts
    65

    Re: Spa Jet Blower problem

    Sure...probably can't get to it until tonight....just a standard spa jet though.
    27ft Above Ground Pool
    Sand filter

  4. Back To Top    #4

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Spa Jet Blower problem

    There are 100's, if not 1000's of different ones.

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  5. Back To Top    #5

    Join Date
    Nov 2007
    Location
    Rockland County, NY
    Posts
    65

    Re: Spa Jet Blower problem

    Quote Originally Posted by PoolGuyNJ
    There are 100's, if not 1000's of different ones.

    Scott
    Huh...Ya live and you learn.

    Either way I'm not sure the problem is jet related. One has a single hole that doesn't move, the other has two holes and spins around. You can adjust flow by turning either CW or CCW..but the problem is there even if the jets themselves are unscrewed from the spa wall.

    Rob
    27ft Above Ground Pool
    Sand filter

  6. Back To Top    #6

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Spa Jet Blower problem

    Your symptoms lead me to believe the air holes have debris clogging them. Do you know what jets and bodies were installed?

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  7. Back To Top    #7

    Join Date
    Nov 2007
    Location
    Rockland County, NY
    Posts
    65

    Re: Spa Jet Blower problem

    I will try to unscrew the jets in question and have a photo for you tonight. Thanks for the help.

    Rob
    27ft Above Ground Pool
    Sand filter

  8. Back To Top    #8

    Join Date
    Feb 2010
    Location
    Houston, TX
    Posts
    271

    Re: Spa Jet Blower problem

    I agree with PoolGuyNJ, sounds like an obstruction. There's not much to the air system - blower, lines, and jets. The blower works fine, so that would pretty much mean an obstruction somewhere.
    John

    24' round Vogue AGP 12,000 gal. Flotec AT251001-01 1HP pump, Hayward S310T2 sand filter, Aquarite SWG T-15
    TF-100 (found at TF Test Kits) with Speedstir and Samplesizer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •