Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Aquabot T2 Impeller problems

  1. Back To Top    #1
    mitch08's Avatar
    Join Date
    Jun 2008
    Location
    Suffolk County, NY
    Posts
    370

    Aquabot T2 Impeller problems

    Ive been using the Aquabot T2 for about 3 years. No complaints until today.

    Today it ran about an hour and when I went to check up on it, it was flipped over.
    It seems like the impeller is not running properly. It is spinning, but maybe just not fast enough to climb.

    If it is walking the floor, it will do fine and pick up dirt. But when it tries getting up a wall, it flips over and stays there.

    When it is working properly, you can tell because there is a lot of water displacement at the surface of the pool on top of the impeller. But now there is no displacement at all. But the impeller is spinning. I dont know how fast it is supposed to so Im not sure if that is the issue, or perhaps there is a clog somewhere else.

    I removed everything, checked all hoses, and everything seems ok. Is it possible something is gunked up in the motor?
    Anyone have any experience with this?

    Thanks in advance!
    18x38 Inground Liner (25k gal) Paver surround, multi-speed pump, DE Filter, Raised spill over spa, TF-100

  2. Back To Top    #2
    frustratedpoolmom's Avatar
    Join Date
    May 2007
    Location
    SWSuburban Chicago, IL
    Posts
    11,963

    Re: Aquabot T2 Impeller problems

    Bump....
    Helpful links: Pool School; CYA/Chlorine Chart
    24' round AG pool, 52" high, Raypak heater; Waterway 2 spd Pump;
    150 Sq ft. Clearwater Cartridge Filter; Former and DISSATISFIED "Pool Frog" owner
    http://www.PerfectlyClearPoolService.com

  3. Back To Top    #3
    mitch08's Avatar
    Join Date
    Jun 2008
    Location
    Suffolk County, NY
    Posts
    370

    Re: Aquabot T2 Impeller problems

    Thanks

    I brought it to an "authorized" service center. $400 in parts and labor.
    Seriously, its basically like bringing in your car to be serviced.

    Anyway, gotta do it but Im not happy about it.
    18x38 Inground Liner (25k gal) Paver surround, multi-speed pump, DE Filter, Raised spill over spa, TF-100

  4. Back To Top    #4

    Re: Aquabot T2 Impeller problems

    Obviously your problem was more serious, but if the cleaner flips over like that when trying to climb the wall, it can also be a symptom that the bag is too full/dirty and needs to be cleaned. Obviously this isn't a problem regularly, but it can be if the pool is really dirty (opening it up for example).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •