Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Goldline Pro Logic Control Panel Issue

  1. Back To Top    #1

    Join Date
    Nov 2009
    Location
    Sacramento
    Posts
    57

    Goldline Pro Logic Control Panel Issue

    Over the past few weeks, my Pro Logic PL-P-4 model has started acting up. The display will flash the current reading (temp, salt level, etc) for about a 1/4 second then go completely blank. It's very difficult to read, so I called the manufacturer (pool is only 5 months old) and they recommended a service company in my area. The service guy came out today while I was at work and then I got a call from the service company saying the service guy indicated everything was working fine. They told me because of the temperature, the control panel is supposed to act that way and that it will until the temperature warms up. I called the manufacturer back and he said that's incorrect. I can't seem to get through to the service company what my issue is, so I requested that the service person that went out there give me a call. From my discussion with the manufacturer, the display is supposed to be on constantly, but will rotate between the various readings, not flash on and off. He said it sounds like a wire may be lose or something electrical. Just wanted to post this on here and make sure I'm understanding how this thing is supposed to work. Thank you!

  2. Back To Top    #2
    polyvue's Avatar
    Join Date
    Aug 2009
    Location
    Sacramento, California USA
    Posts
    1,215

    Re: Goldline Pro Logic Control Panel Issue

    Quote Originally Posted by jason92s
    From my discussion with the manufacturer, the display is supposed to be on constantly, but will rotate between the various readings, not flash on and off.
    That is certainly the way the precursor to the Pro Logic works. How cold is the air temperature where you are? I've been outside when the air was 26° F. and the pool temp was below 45° F. and the [Aqua Logic] PS-8 display rotated through its readings just as you describe --- no flickering or flashing of any kind. It's possible that the display unit hasn't been seated fully or correctly in the cut-out, or something else (a wire connection) is loose. It's definitely not a normal occurrence.

    Welcome to the forum
    14,555 gal in-ground 16'x29' white plaster Pool w/spa (2007); Goldline Aqua Logic AQL-PS-8 control w/Aqua Cell 15 Salt Water Chlorination (SWCG); Hayward TriStar 1HP (1.85 SF) main / 1.5HP (1.60 SF) spa pumps; Hayward Swimclear cart filter C4025, ColorLogic LED lights; Tankless SP-18-4 electric heater; Polaris 280 cleaner.
    __
    View of spiral galaxy in Ursa Major NGC6217 - Hubble Telescope 2009

  3. Back To Top    #3

    Join Date
    Nov 2009
    Location
    Sacramento
    Posts
    57

    Re: Goldline Pro Logic Control Panel Issue

    Thank you for the reply. The temperature has been in the 40's to 50's lately. Probably as low as 28 over the past month. It's just so frustrating trying to deal with the service company!

    Again, thank you and I'm glad I found this site (a friend told me about it). So much great information on here!

  4. Back To Top    #4
    polyvue's Avatar
    Join Date
    Aug 2009
    Location
    Sacramento, California USA
    Posts
    1,215

    Re: Goldline Pro Logic Control Panel Issue

    Quote Originally Posted by jason92s
    Thank you for the reply. The temperature has been in the 40's to 50's lately. Probably as low as 28 over the past month. It's just so frustrating trying to deal with the service company!
    Glad you're here.

    The unit is five months old and obviously still under warranty -- this might be something you can fix yourself if you're a bit handy (and careful); otherwise, insist on getting a service call from a competent technician and have it either fixed or swapped for a new unit.
    14,555 gal in-ground 16'x29' white plaster Pool w/spa (2007); Goldline Aqua Logic AQL-PS-8 control w/Aqua Cell 15 Salt Water Chlorination (SWCG); Hayward TriStar 1HP (1.85 SF) main / 1.5HP (1.60 SF) spa pumps; Hayward Swimclear cart filter C4025, ColorLogic LED lights; Tankless SP-18-4 electric heater; Polaris 280 cleaner.
    __
    View of spiral galaxy in Ursa Major NGC6217 - Hubble Telescope 2009

  5. Back To Top    #5

    Join Date
    Nov 2009
    Location
    Sacramento
    Posts
    57

    Re: Goldline Pro Logic Control Panel Issue

    Yeah, it's been raining non-stop for several days now, so I'm waiting for a break to go out there and take it apart. Here's a rough video I just shot that shows the flickering/blinking. It's off my iPhone, so it's not great quality, but you can see what I'm talking about. It blinks in at the 9, 13, 20, 25, and 33 second mark.

    [youtube:2lafdv3q]KkXwFBv1mYg[/youtube:2lafdv3q]

  6. Back To Top    #6

    Join Date
    Oct 2007
    Location
    Valrico, FL
    Posts
    500

    Re: Goldline Pro Logic Control Panel Issue

    I don't think that the spa/pool light is suppose to be blinking either.
    7,500 gal, IG pool, L shape 22' x 15', 1.5 hp pump, cartridge filter, AquaPlus SWG/Controller, Pebble-Tec liner.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •