Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Major LEAK on top of sand filter at the valve handle!!! HELP!!!

  1. Back To Top    #1

    Join Date
    Apr 2017
    Location
    Murrieta
    Posts
    5

    Major LEAK on top of sand filter at the valve handle!!! HELP!!!

    I'm a total pool newbie and not very handy although more handy than my husband so here it goes. Lol! We purchased a new Summer Waves 16'x48" round pool. Also got the Summer Waves sand pump and a Summer Waves saltwater system. Everything seems to be working except for the fact that water is flowing out through the top of the sand filter coming out of the valve handle area spilling into the label that shows, "backwash, rinse, filter, etc." We ran the first 1 min backwash and rinse... it seemed okay, we set it in the filter mode next and it started leaking. No other leaks, just that area. I'm on Day 2 of trying to figure this out. Yesterday I had the same thing happen along with other leaks and I decided to just take it all apart and returned it thinking it was defective. This was after 3 calls to customer service and they were no help other than to tell me to lubricant the "O" rings which I did today before set up. That helped with all other leaks except for the major one spilling out from the handle area on the top. Could the saltwater system be causing any of this? We haven't turned that on yet however the water does come out of the sand pump and in through the saltwater system then makes its way back into the pool. The water seems to be returning to the pool fine and it looks really good other than that leaking that's going to cause the label to peal off! Oh how I hope someone can troubleshoot this please!!!!

  2. Back To Top    #2

    Join Date
    Apr 2017
    Location
    Murrieta
    Posts
    5

    Re: Major LEAK on top of sand filter at the valve handle!!! HELP!!!

    Photo of area it's leaking....Attachment 61274

  3. Back To Top    #3

    Join Date
    May 2017
    Location
    Des Moines, IA
    Posts
    25

    Re: Major LEAK on top of sand filter at the valve handle!!! HELP!!!

    You're photo didn't attach.

    When you say it is leaking from the handle, is it leaking from the handle itself, from the black screw down ring, or where the multi-port valve attaches to the sand filter?
    16' Polygroup Pro-Series AG-5,200 Gal
    Upgraded Hayward Skimmer & Return, Hayward Super Pump, Hayward C1200 Starclear Plus Cartridge Filter
    Rolachem 554120 pH Liquid Acid & ORP Liquid Chlorine Automated Controller System & 2 12 GPD Peristaltic Pumps

  4. Back To Top    #4

    Join Date
    Apr 2017
    Location
    Murrieta
    Posts
    5

    Re: Major LEAK on top of sand filter at the valve handle!!! HELP!!!

    Yes, the water is coming up just below the handle where the handle attached to the multi-port valve and that attached to the sand filter. So leaking right out and on that circular label and spilling down the sand filter. Any ideas?

    - - - Updated - - -

    IMG_7387.jpg

  5. Back To Top    #5

    Join Date
    May 2017
    Location
    Des Moines, IA
    Posts
    25

    Re: Major LEAK on top of sand filter at the valve handle!!! HELP!!!

    We had the same filter, emphasis on the word had. Had the same problems you were having. After lots of research ended up discovering that filter is very picky when it comes to head pressure in the return line. Unfortunately I don't have a good answer for you, we tried 3 different units and had problems with each before we ended up purchasing a different setup.
    16' Polygroup Pro-Series AG-5,200 Gal
    Upgraded Hayward Skimmer & Return, Hayward Super Pump, Hayward C1200 Starclear Plus Cartridge Filter
    Rolachem 554120 pH Liquid Acid & ORP Liquid Chlorine Automated Controller System & 2 12 GPD Peristaltic Pumps

  6. Back To Top    #6

    Join Date
    Apr 2017
    Location
    Murrieta
    Posts
    5

    Re: Major LEAK on top of sand filter at the valve handle!!! HELP!!!

    Thank you! I'm thinking after my now 5 calls into Customer Service and my now second purchase trying to get this filter working, I need to get both of these sand filters returned and buy something else.... hopefully the intex sand filter will connect to our pool with ease. I'm on day 4 of dealing with this all day long.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •