whisperflo

  1. maxxis

    Pump Replacement 2-speed to Variable Speed Pump & Panel Upgrade Advice

    Hi all, Looking for advice on replacing my failing rebuilt Whisperflo II 2-speed 1-hp 240V pump controlled by a 2004 Intellitouch/easy touch P4 system (motherboard upgraded to UOC: 2.160, Bootloader UOC: 1.010). In addition to the pump, the system controls a Jandy Valve for the solar panels, the...
  2. N

    Found algae built up in Whisperflo …. Please help

    We have Pentair Whisperflo which is mainly used for the waterfall. We usually have it run 15 minutes weekly up until we had our freeze back in February. Since then, we have minor leak with the pump so we only run it for waterfall only when we need to, not weekly anymore. Today, I found algae...
  3. B

    New Pump Motor - Leaking From Bolt Hole

    I replaced the motor (century motor B2854) on my Whisperflo pool pump (Schematic). I bought a new seal kit, and replaced items 11, 16, and 9. On 11 and 9 I used some lubricant when installing. On 16, I put some silicone around the side that goes into the seal plate, and nothing around the side...
  4. N

    Pentair Whisperflo frozen ... found crack

    Hi, I noticed there is another post with similar situation where my Pentair Whisperflo frozen during Texas freeze and now I find some cracks on my pump. See the attached images. Im trying to apply epoxy along these cracks and am waiting for it to cure to see if that would work. I also...
  5. U

    Help Troubleshooting Pentair WhisperFlo Priming Issue (just replaced motor bearings)

    I am hoping someone can help me here. I've been banging my head against a wall on this the past two days. Background: The bearings / seal were shot on my ~10 year old WhisperFlo pump. The sound became ungodly, and it was slowly leaking water, so I bit the bullet on Thursday and pulled the motor...